2

Firefox stopped working the other day and I can't get it to work again. When I try to run in, it just hangs there, CPU goes to 100% (according to "top") and it will shortly ask me if I want to keep waiting or force quit (waiting does nothing).

I have purged firefox

deleted ~/.mozilla

deleted /etc/firefox/

deleted /usr/lib/firefox/

deleted /usr/lib/firefox-addons/

Tried to run in --safe-mode several times, nothing seems to work.

Now I have tried to submit this to ubuntu running ubuntu-bug firefox and I see several errors in there but I don't know where to go from here. Googling those errors didn't help. Can anybody please help me to continue troubleshooting in some way?

enter image description here

Edit:

Using the default firefox installed from the local repository: Mozilla Firefox 78.0.1

Ubuntu version: Ubuntu 20.04 LTS

I have also tried to run firefox directly from the file I got from firefox.com but had the same outcome.

Edit2:

This first happened when I tried to run firefox from a script using Selenium and the Firefox Gecko Driver. At the time, I had an instance of firefox already running and the script quit with a connection issue. Closed all firefox windows and it didn't work anymore since then.

It had never done this before while I have tested the script and used it a lot everyday. I also tried to delete the gecko driver from the $PATH.

4
  • Please edit youor question with information about which version of Ubuntu and FF you are using and how FF was installed.. by default when you installed Ubuntu or by some other means. – 24601 Jul 5 '20 at 10:55
  • I have edited the question. Firefox was first installed with Ubuntu, now tried to reinstall it from the same repository. – Sergiu Elmi Jul 5 '20 at 11:00
  • What happens if you try to launch FF from a terminal? With the command firefox – kc1di Jul 5 '20 at 11:01
  • same thing. And when I force quit it just says "Exiting due to channel error. Killed". No other promp – Sergiu Elmi Jul 5 '20 at 11:03
1

I have used lsof -p and saw it was looking a lot in the var/cache/fontconfig and ~/.cache/fontconfig folders and just remembered I have used font-manager and enabled a folder in there with a shit load of fonts.

Oddly enough, those fonts were not installed in the system but this was the culprit. Happy to say it's working again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.