After running the upgrade from 11.10 to 12.04, the upgrade manager crashed during the installation portion.

Now, when I run the update manager, it tells me:

Not all updates can be installed.
Run a partial upgrade, to install as many updates as possible.

However, when I click "Partial Upgrade," I get this error:

Failed to run /usr/bin/update-manager '--dist-upgrade' as user root.
Unable to copy the user's Xauthorization file.

How can I get my upgrade to finish?

I have tried several suggestions I've found on the internet, including sudo dpkg --configure -a, but always get errors.

  • 1
    Not sure if this will work or not, so I am putting it in as a comment. Do a do apt-get dist-upgrade in the terminal and see if that works. – TheXed Apr 26 '12 at 23:14

In such cases I solve this problem by using terminal instead Upgrade Manager:

  1. Update sourcelists. First check you use right sourcelists:

    sudo apt-get update


  2. Use diagnostic checker (Update + Diagnostic broken dependecies):

    sudo apt-get check


  3. Upgrade distribution (This is the equivalent of "Mark all upgrades" in Synaptic):

    sudo apt-get upgrade
  4. "Smart upgrade". It tells APT to use "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones if necessary. :

    sudo apt-get dist-upgrade

For other cases read this article:
AptGet/Howto: Package management with APT


I ran into a similar issue, where the installer was complaining about a printer driver. Try removing the Xauthorization file from the /var/lib/dpkg/status. Then run the sudo dpkg --configure -a command. You can always manually copy the Xauthorization file again after the upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.