I just installed Ubuntu 12.04 by cd. Unity 3D will not work now only 2D It worked fine in 11.10 and also when I upgraded to the beta of 12.04 through update manager. I tried both Nvidia Proprietary Drivers on the list with no luck. I had many more driver choices in 11.10 and 12.04 beta but the default installed driver always worked before this install. I get a black screen and the wall paper sometimes shows for a few seconds and then goes back to the black screen using Unity 3D.

1 Answer 1


You may be affected by Bug #982485 if Unity 3D was working on the Beta, but isn't working now. It looks like it is affecting Geforce 6*** and Geforce 7*** cards. Nvidia is aware of the bug, so hopefully there will be a fix rolled out soon.

If you want Unity 3D to work in the meantime, try to add the Ubuntu-X Updates PPA and downgrade the nvidia-current package to 295.33.

(tip for GUI users: use Ctrl+Alt+F1 to get to a text mode login, then type in your login/password at the command line interface to get to a place where you can issue the following commands)

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current=295.33-0ubuntu1~precise~xup1

Important notes:

  • There was a security bug in 295.33 so you have to factor this into your decision about whether or not to downgrade.

  • You will have to uncheck the nvidia-current package from the Update Manager when you upgrade your system to prevent it from re-installing version 295.40.

Whether or not you downgrade your nvidia driver, watch the bug listing (or subscribe to it) to know when the bug gets fixed so you can upgrade your driver then.

  • Known to work on (my) Dell Dimension E521 (Nvidia GeForce 6150LE). Note that just before doing this (at around 21:15 PDT today), I also did "sudo apt-get update ; sudo apt-get upgrade" to be sure my release was up to date. ... ... I wish I had realized just how incredibly new (less than a week) the 12.x LTS release was (before I installed it instead of 10.x, with which I have had good luck). The latest update/upgrade of 12 pulled up many changes released in the last 24 hours.
    – Roboprog
    May 2, 2012 at 4:32
  • This didn't work for me I downgraded to 295.33 (or so I think) but I still can't get Unity 3D to work, is there something I can provide you to get this to work.
    – LEOPiC
    May 3, 2012 at 1:47
  • Nvidia released a new version today (295.49) that should fix the bug mentioned here. I would wait until it gets packaged for 12.04 then upgrade.
    – jamesadney
    May 3, 2012 at 17:15
  • Sadly I already upgraded, the workaround worked fine for me in one of my machines, it didn't in the other, I'll use Ubuntu 2D for now, thanks!
    – LEOPiC
    May 5, 2012 at 5:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .