0

I have experimented with different gnome extensions to control the performance and battery life on my laptop. Notably, I installed and uninstalled these two extensions:

I partly run them at the same time, then uninstalled and reinstalled them. Now my CPUs are stuck at the minimum frequency and changing the governor has no more effect.

user@XPS:~$ cat /proc/cpuinfo | grep MHz
cpu MHz     : 800.039
cpu MHz     : 800.035
cpu MHz     : 800.037
cpu MHz     : 800.026
cpu MHz     : 800.008
cpu MHz     : 800.036
cpu MHz     : 800.040
cpu MHz     : 800.028

user@XPS:~$ for governor in $(ls /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor); do cat $governor; done
performance
performance
performance
performance
performance
performance
performance
performance

How can I trouble-shoot this?


Here some more information:

The CPUs remain at 800 Mhz even under load. (I tested it running 0.A.D. with six bots on a large map.)

user@XPS:~$ grep . /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver
/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu4/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu5/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu6/cpufreq/scaling_driver:intel_pstate
/sys/devices/system/cpu/cpu7/cpufreq/scaling_driver:intel_pstate

user@XPS:~$ grep . /sys/devices/system/cpu/cpu*/cpufreq/scaling_max_freq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu4/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu5/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu6/cpufreq/scaling_max_freq:3800000
/sys/devices/system/cpu/cpu7/cpufreq/scaling_max_freq:3800000

user@XPS:~$ grep . /sys/devices/system/cpu/cpu*/cpufreq/scaling_min_freq
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu4/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu5/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu6/cpufreq/scaling_min_freq:800000
/sys/devices/system/cpu/cpu7/cpufreq/scaling_min_freq:800000

user@XPS:~$ grep . /sys/devices/system/cpu/intel_pstate/*perf_pct
/sys/devices/system/cpu/intel_pstate/max_perf_pct:100
/sys/devices/system/cpu/intel_pstate/min_perf_pct:25
  • 1
    Start with what CPU frequency driver? Do grep . /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver. Next, what are the max and mins? Do: grep . /sys/devices/system/cpu/cpu*/cpufreq/scaling_max_freq and grep . /sys/devices/system/cpu/cpu*/cpufreq/scaling_min_freq and if your driver is intel_pstate: grep . /sys/devices/system/cpu/intel_pstate/*perf_pct. then we'll go from there. Note: I never ever use any of those add on tools. Oh, and if you have no load at all (unlikely in a desktop (O.K. LapTop) with a GUI), you might well see 800 MHz, even in performance mode. – Doug Smythies Jul 2 at 18:46
  • Yes if you give it no work the frequency is low. Try running a computation and rerun your command. – Yvain Jul 2 at 18:54
  • I added the above requested information. Even under heavy load the frequency remains constantly 800 Mhz. – mace Jul 2 at 19:26
  • If your processor is HWP capable, try to disable it. You could also try to disable the intel_pstate driver entirely, witch would then cause the acpi-cpufreq driver to be used. These are all grub GRUB_CMDLINE_LINUX_DEFAULT options, intel_pstate=disable and intel_pstate=passive intel_pstate=no_hwp. I would very much like to understand your issue. – Doug Smythies Jul 2 at 20:11
  • Actually, first try this echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor and does that un-stick it? are there any indications of thermal events in any of your log files? – Doug Smythies Jul 2 at 20:17
0

After checking different options in grub with no result, I booted a clean ubuntu image from USB. The CPU frequency was still at 800 Mhz indication that it wasn't OS related. A quick search yielded that this is a Dell safeguard mechanism to protect the laptop and is triggered by a thermal event, bad battery, or faulty charger. In my case, it was probably a thermal event I had at the same time I experimented with the above-mentioned extensions. My laptop failed to sleep and went full throttle in my rucksack sometime last week.

The solution was to unscrew the back-lid and disconnect the battery for >15 seconds. This resets the safeguard mechanism. After reboot the CPU is again following the intel_pstate settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.