18

This happens in two different computers, one with Ubuntu 20.04 and another with 18.04.

The left 40% of the tablet maps horizontally to the entire monitor, while vertically it works fine - bottom to top in the tablet is bottom to top in the monitor. The remaining 60% of the tablet is unused. Both computers are dual boot with Windows 10 and the tablet works fine in both.

Is there a way to map the entire tablet area to the entire monitor?

I tried configuring the Wacom tablet using the settings in Ubuntu. I chose tablet absolute and relative, I clicked "map to a single monitor" in the option Map to monitor.

I tried xsetwacom in command line. Following these instructions:

https://ubuntu-mate.community/t/scale-your-wacom-tablet-to-a-single-monitor/8036

I tried setting:

xsetwacom --get "Wacom Co.,Ltd. Intuos S stylus" area
0 0 15200 9500

If I change it to a larger horizontal value:

xsetwacom --set "Wacom Co.,Ltd. Intuos S stylus" area 0 0 30400 9500

The tablet area remains unchanged, but the pen does not go to the horizontal end of the monitor. If I change it to a smaller number (smaller than 15200) then the tablet area where the pen is "active" is reduced.

I also tried:

xsetwacom --set "Wacom Co.,Ltd. Intuos S stylus" MapToMonitor eDP-1

where eDP-1 is my monitor name from typing xrandr.

Thanks for any help!

Update

There is a weird behaviour here. If I switch on my computer with the tablet already plugged in, it works fine! If I plug in the tablet after the computer is on, the problem reported above happens.

If, when it is working fine, I disconnect the tablet and then connect again, the problem above also happens.

4
  • 1
    Are you using two monitors?
    – bashBedlam
    Jul 1, 2020 at 23:50
  • No, I have only one monitor in both computers (one is a desktop, the other a laptop). Jul 1, 2020 at 23:56
  • I updated my question. I found a weird pattern. Jul 2, 2020 at 0:22
  • 1
    I also get the same issue. I use two monitors, but that seems irrelevant. Only the first roughly 40% on the left works, while the vertical works flawlessly. Even mapping with an offset has no effect on the rightmost part of the tablet. No issue on Windows. It seems like a driver problem.
    – Signal
    Jul 3, 2020 at 18:19

1 Answer 1

41

Hold the left-most and the right-most buttons until the LED turns off and back on.

https://github.com/linuxwacom/xf86-input-wacom/wiki/Known-Issues#android-misdetect

5
  • 2
    Amazing! Perfect, not only solved the problem but also taught me about the Android/PC mode! Jul 4, 2020 at 20:11
  • This fixed the issue for me as well! Weird little problem for Ubuntu users Sep 9, 2020 at 22:25
  • Wow!! this worked as a charm! Sep 11, 2021 at 1:04
  • Thanks for the info! I have the same problem, however, when I switch to PC mode (by holding the 2 buttons) Ubuntu then stops registering my Intuos at all. Any idea?
    – J-J
    Feb 11 at 22:45
  • The vendor ID will change in lsusb, make sure you can still see it. Is it wired or Bluetooth? I suggest you open an issue on their GitHub: github.com/linuxwacom/xf86-input-wacom
    – Signal
    Feb 13 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.