I've been trying to install Ubuntu 12.04 LTS on my desktop most of the day. The desktop uses a NVIDIA GEFORCE 9800 (GT I think) graphics card. I am unable to set the correct resolution (1680 x 1050) for the display.

The first problem I had was that of the "Black Screen" during install. I overcame this by utilising the "nomodeset" switch on the install options (once I'd found how to do that). The second problem of course was the "Black screen" following the first reboot. Once again this was overcome by using "nomodeset", this time by "editing" the GRUB.

This gave me a resolution of 1280x768 which, the Displays GUI allowed me to change to 1280x720 (appears to fit on screen).

I then tried to install the NVIDIA drivers. 1) using additional drivers 2) manually by downloading driver and installing in root

As soon as NVIDIA drivers are installed - resolution become restricted to 640x480 (max). At this resolution Ubuntu GUI is not usable as most screens are larger than the display. Removing the NVIDIA driver and removing the XORG.CONF file does not lift this restriction.

I have tried most things that I have found and that were vaguely intelligible, but nothing appears to get me closer to a resolution of 1680x1050.

UPDATE: reinstalled Ubuntu 12-04 and used the "NoModeSet" in the Grub to restore the resolution to 1280x720, which is at least usable. Will live with this for now.

  • X11 fails to initialize with my NVidia 9800 GTX+ fresh install on 12.04 32bit. did you have any issues getting it to work out of the box? – rlemon Apr 30 '12 at 19:04

I have been having resolution problems with my brand new Ubuntu 12.04 LTS installation and I couldn' t even see the choice of the 1680x1050 resolution. But then it was so easily and user-friendly solved: Just went to Additional Drivers in the System Settings tab and activated the NVIDIA accelerated graphics driver(post-release updates)(version current-updates) and it worked for me. Good luck!

  • Thanks for the suggestion, tsinaski. I tried this (although I think I have tried it before!). The system is now locked into 640x480 (max) resolution once more - that is not usable. Previous experience tells me the only way to circumvent this is to re-install Ubuntu! I think I'll forget it and stick to Windows. – Daveisuser56810 Apr 27 '12 at 16:24
  • Actually I realised that you can "unlock" the false 640x480 max resolution after all (I think previously I had attempted installs of both proffered NVIDIA drivers - 'current' and 'current updates' but in my frustration I had forgotten this. When the latest NVIDIA driver is removed, the system automatically reverts to the earlier NVIDIA driver; thus removing that NVIDIA driver reverts the system back to the basic Ubuntu driver (vesa?) which gives me the option of 1280x768 and 1280x720 once more. Hurrah! a workable system - not perfect, but usable. – Daveisuser56810 Apr 27 '12 at 23:46

A few weeks ago, my system suddenly dropped down to 800x600, but there was no any problem the day before, it just happened! Then I started reinstalling Ubuntu, and what you describe started coming out. And jockey ("Additional Drivers" in the setting panel) even fail to activate nvidia-current.

Now I believe that it's the monitor that causes the problems. My monitor is of an unknown manufacturer and now some quality problems have been showing up. I think hardware issues is the only explanation to all these strange things. Try reinstalling Ubuntu after changing your monitor and see if the NVIDIA driver can be install. I haven't try this yet.

  • It worked! After I changed my monitor, the resolution issue had gone! Obviously it was because Ubuntu couldn't detect my broken monitor. – seamlik Oct 2 '12 at 6:47

There are a lot of issues with the 295.40 driver. You can revert to the old nvidia driver 295.33 by following this guide:


I have to manually load the nvidia_current kernel module by adding nvidia_current to /etc/modules -- works after reboot, executing "modprobe nvidia_current" and "/etc/init.d/lightdm restart" works immediately


nomodeset helped during install. After then the screen went all wacko so I remember a youtube video I was watching which it stated to run a fix during boot by running fix all problems. If that did not help try running it in the safe graphics mode and update the card. It worked for me.


http://ubuntuforums.org/showthread.php?t=1628678 I had a very similar issue and this link resolved it for me. Give it a shot!

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Peachy Sep 23 '12 at 4:17

UPDATE: Ubuntu 12.04 upgrade: Use Nvidia X server config app to adjust resolution, picking one ** close resolves issue after upgrade. Actual didn't work.

nVidia GeForce 6150 GPU onboard chipset

Purpose of this post is to assist in activating proprietary driver for onboard 6150 DVI connection to LCD with HDMI connect.

Maverick 10.10

Linux version 2.6.35-28-generic, NVIDIA GLX Module 260.19.06

The nouveau driver installed by default recognizes LCD monitors connected by DVI/HDMI. This default driver cannot fully utilize the 3D potential of NVIDIA graphics chips or provide 2D acceleration for newer cards. The default resolution choices tend to be below the capabilities of monitor/tv and chipset.

If you are considering the installation of the proprietary drivers found under System, Administration, Additional Drivers some preliminary work will ease the process.

Without some changes to the xorg.conf file many people have experienced over-scan issues and blank or black screen on reboot post driver install.

Before choosing install look in Log File Viewer under System Administration for Xorg log. The Nouveau driver logs some useful information about your graphics system. Look for chipset info: "NVIDIA NV4e" and the lines after "Supported standard timings".


17.661] (II) NOUVEAU(0): #0: hsize: 1280 vsize 1024 refresh: 60 vid: 32897 17.661] (II) NOUVEAU(0): #1: hsize: 1360 vsize 765 refresh: 60 vid: 49291

You can read more about EDID.

The hsize and vsize should be close to resolutions supported by your monitor. Verify these by looking in the manual for the monitor or online at manufacturers website. The supported resolutions have to be manually added to xorg.conf.

Look for the xorg.conf file under /etc/X11/xorg.conf. You can add, if not there or edit, by opening the terminal application found under accessories and typing

$ sudo gedit /etc/X11/xorg.conf

Add or edit the Screen section of xorg.conf. This example applies to 720p 32" widescreen lcd tv.

Section "Screen"
Identifier  "Default Screen"
DefaultDepth    24
Option  "UseDisplayDevice" "DFP"
Subsection  "Display"
   Modes    "1360x768" "1280x720" "720x480"

Substitute the display Modes shown above for the resolutions supported by your LCD monitor. The first mode "1360x768" will be the default read by nVidia driver upon installation.

The option "UseDisplayDevice" "DFP" will select the dvi connected LCD. This should prevent the black screen upon reboot.

After you've saved the file, activate the driver.

Additional information for nVidia with XOrg commands.

  • I tried to follow this suggestion, thanks. Unfortunately, I fell at the first hurdle. In the log file "Xorg.O.log" the text "NVIDIA NV4e" and also "Supported standard timings" does not appear. However... The log does show a lot of information including the following... [27.713] (II) VESA(0): <default monitor>: Using default hsync range of 31.50-48.00 kHz [27.713] (II) VESA(0): <default monitor>: Using default vrefresh range of 50.00-70.00 Hz [27.713] (II) VESA(0): <default monitor>: Using default maximum pixel clock of 65.00 MHz – Daveisuser56810 May 1 '12 at 23:37
  • I've had a look at the suggested Xorg information, but I'm afraid that I'm not confident to actually interpret this correctly, especially given that without the NVIDIA drivers installed there is no "Xorg.conf" file to start me off. – Daveisuser56810 May 1 '12 at 23:45
  • This answer is very hard to read. Please improve. – con-f-use Aug 18 '12 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.