I am trying to run MCPE on Linux, I've set everything up, but when I run the game I get this error:

/tmp/.mount_MinecrC0c2NX/usr/bin/./mcpelauncher-client: error while loading shared libraries: libEGL.so.1: cannot open shared object file: No such file or directory
Process exited with unexpected exit code: 127

I've tried installing libegl1:i386, but I get another error:

The following packages have unmet dependencies:
 libegl1:i386 : Depends: libc6:i386 (>= 2.7) but it is not going to be installed
                Depends: libglvnd0:i386 (= 1.3.1-1) but it is not going to be installed
                Depends: libegl-mesa0:i386 but it is not going to be installed

I am using Ubuntu 20.04 64-bit

  • You've gotten yourself into "dependency hell". You will hzve to install libEGL's dependencies, their dependencies, their dependencies, ... . Keep going, there" s an end eventually.
    – waltinator
    Jul 1, 2020 at 0:56
  • The following packages have unmet dependencies: gcc-10-base : Breaks: gcc-10-base:i386 (!= 10.1.0-1) but 10-20200411-0ubuntu1 is to be installed gcc-10-base:i386 : Breaks: gcc-10-base (!= 10-20200411-0ubuntu1) but 10.1.0-1 is to be installed I've tried to do that and got this
    – user1096012
    Jul 1, 2020 at 6:54
  • Try sudo dpkg --add-architecture i386 , sudo apt-get update followed by sudo apt-get install -f .
    – N0rbert
    Jul 1, 2020 at 7:08
  • @N0rbert I did that and it just gave me a list of packages that were automatically installed and are no longer required
    – user1096012
    Jul 1, 2020 at 7:48
  • Then it is time for sudo apt-get install libegl1:i386 .
    – N0rbert
    Jul 1, 2020 at 8:04

1 Answer 1


I managed to fix it myself. My friend told me to use aptitude to install the packages, so I ran sudo aptitude install libegl1:i386, then I used sudo aptitude install libc6-i386 libx11-6:i386 libegl1-mesa:i386 zlib1g:i386 libstdc++6:i386 libgl1-mesa-dri:i386 libasound2:i386 libpulse0:i386

You must log in to answer this question.