When using update-manager -d, sudo do-release-upgrade, or using the GUI, I get several errors.

The first being update-manager -d brings up the update manager just fine, shows the upgrade option just fine, but when I click on upgrade, I get the "Beta Version" that shows up.

Then the remaining errors involve adobeflashplugin and adobe-flash-propertiesgtk, which are uninstalled, but the upgrader insists they're causing an error.

I've tried this but it doesn't work:

Also, I downloaded the ISO via torrent from Ubuntu site, the md5s check out, and using UNetbootin and burning ISO to disc, I do not get an upgrade option at all. I get the options to install 12.04 along side, erase the partitions, or something else.

My update manager is set for LTS releases only. I've also disabled extra sources (Medibuntu, for example). Not sure if I'm doing something wrong or not.

I've tried this but it doesn't work:

Using 32bit 10.04, trying to upgrade to 32bit 12.04, on an Acer Aspire One netbook (D250 model).

Any help would be appreciated and thanks in advance.


2 Answers 2


Not quite sure what I did, but the upgrade is finally going through. I think for whatever reason, the netbook version of 10.04 didn't like wanting to upgrade via disc or usb.

However, using the same disc on my tower, the upgrade option was present and went through fine.

My advice for anyone else with this error, just keep trying.


I would like to prefer you fresh installation of 12.04 for avoiding any upgrade error and Bandwidth wastage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.