2

Hello I try to install wine-stable in my ubuntu 18.04, but I am not able to install it, all of them depend on the packages I have installed already.

$ sudo apt install wine-stable

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable-amd64 : Depends: libfaudio0 but it is not installable
                     Recommends: libcapi20-3 but it is not going to be installed
                     Recommends: libodbc1 but it is not going to be installed
                     Recommends: libosmesa6 but it is not going to be installed
 wine-stable-i386:i386 : Depends: libasound2:i386 (>= 1.0.16)
                         Depends: libfaudio0:i386 but it is not installable
                         Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not going to be installed
                         Depends: libgphoto2-6:i386 (>= 2.5.10) but it is not going to be installed
                         Depends: libgphoto2-port12:i386 (>= 2.5.10) but it is not going to be installed
                         Depends: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) but it is not going to be installed
                         Depends: libgstreamer1.0-0:i386 (>= 1.4.0) but it is not going to be installed
                         Depends: liblcms2-2:i386 (>= 2.2+git20110628) but it is not going to be installed
                         Depends: libldap-2.4-2:i386 (>= 2.4.7) but it is not going to be installed
                         Depends: libmpg123-0:i386 (>= 1.13.7) but it is not going to be installed
                         Depends: libopenal1:i386 (>= 1.14) but it is not going to be installed
                         Depends: libpcap0.8:i386 (>= 0.9.8) but it is not going to be installed
                         Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
                         Depends: libudev1:i386 (>= 183) but it is not going to be installed
                         Depends: libx11-6:i386 but it is not going to be installed
                         Depends: libxext6:i386 but it is not going to be installed
                         Depends: libxml2:i386 (>= 2.9.0) but it is not going to be installed
                         Depends: ocl-icd-libopencl1:i386 but it is not going to be installed or
                                  libopencl1:i386
                         Depends: ocl-icd-libopencl1:i386 (>= 1.0) but it is not going to be installed or
                                  libopencl-1.1-1:i386
                         Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed
                         Depends: libasound2-plugins:i386 but it is not going to be installed
                         Depends: libncurses6:i386 but it is not installable or
                                  libncurses5:i386 but it is not going to be installed or
                                  libncurses:i386 but it is not installable
                         Recommends: libcapi20-3:i386 but it is not going to be installed
                         Recommends: libcups2:i386 but it is not going to be installed
                         Recommends: libdbus-1-3:i386 but it is not going to be installed
                         Recommends: libfontconfig1:i386 but it is not going to be installed
                         Recommends: libfreetype6:i386 but it is not going to be installed
                         Recommends: libglu1-mesa:i386 but it is not going to be installed or
                                     libglu1:i386
                         Recommends: libgnutls30:i386 but it is not going to be installed or
                                     libgnutls28:i386 but it is not installable or
                                     libgnutls26:i386 but it is not installable
                         Recommends: libgsm1:i386 but it is not going to be installed
                         Recommends: libgssapi-krb5-2:i386 but it is not going to be installed
                         Recommends: libkrb5-3:i386 but it is not going to be installed
                         Recommends: libodbc1:i386 but it is not going to be installed
                         Recommends: libosmesa6:i386 but it is not going to be installed
                         Recommends: libpng16-16:i386 but it is not going to be installed or
                                     libpng12-0:i386 but it is not installable
                         Recommends: libsane:i386 or
                                     libsane1:i386 but it is not going to be installed
                         Recommends: libsdl2-2.0-0:i386 but it is not going to be installed
                         Recommends: libtiff5:i386 but it is not going to be installed
                         Recommends: libv4l-0:i386 but it is not going to be installed
                         Recommends: libxcomposite1:i386 but it is not going to be installed
                         Recommends: libxcursor1:i386 but it is not going to be installed
                         Recommends: libxfixes3:i386 but it is not going to be installed
                         Recommends: libxi6:i386 but it is not going to be installed
                         Recommends: libxinerama1:i386 but it is not going to be installed
                         Recommends: libxrandr2:i386 but it is not going to be installed
                         Recommends: libxrender1:i386 but it is not going to be installed
                         Recommends: libxslt1.1:i386 but it is not going to be installed
                         Recommends: libxxf86vm1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Output of apt file:

###### Ubuntu Main Repos
deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse

###### Ubuntu Update Repos
deb http://archive.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse


deb https://deb.torproject.org/torproject.org bionic main
 
# deb http://http.kali.org/kali kali-rolling main non-free contrib
# deb-src http://http.kali.org/kali kali-rolling main non-free contrib
deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main

Output lsb_release:

 $ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="kodachi"

I tried everything and I saw another post : Can't install wine stable on Ubuntu 19.10 (depends on wine-stable)

But it's 19.10, I think I can also update it but I tried also apt autoremove etc.

1
  • 1
    You first need to resold the last error. "held broken packages" Once that is gone you can try Wine again. try sudo dpkg --configure -a and sudo apt install -f – walttheboss Jun 30 '20 at 21:31