1

I try to compile a program called ip sla responder (https://github.com/cmouse/ip-sla-responder). i copied everything into a temp directory.

root@srvmwips01:/tmp/ip-sla-responder-master# ls -l
total 128
-rw-r--r-- 1 ipsla ipsla  1072 Nov  9  2018 LICENSE
-rw-r--r-- 1 ipsla ipsla   641 Nov  9  2018 Makefile
-rw-r--r-- 1 ipsla ipsla  3143 Nov  9  2018 README.md
-rw-r--r-- 1 ipsla ipsla  2421 Nov  9  2018 arp.c
-rw-r--r-- 1 ipsla ipsla  8312 Nov  9  2018 cisco.c
-rw-r--r-- 1 ipsla ipsla  1946 Nov  9  2018 ether.c
-rw-r--r-- 1 ipsla ipsla  3229 Nov  9  2018 icmp4.c
-rw-r--r-- 1 ipsla ipsla  2320 Nov  9  2018 icmp6.c
-rw-r--r-- 1 ipsla ipsla  2413 Nov  9  2018 ip.c
-rw-r--r-- 1 ipsla ipsla  2368 Nov  9  2018 ip6.c
-rw-r--r-- 1 ipsla ipsla  3506 Nov  9  2018 junos.c
-rw-r--r-- 1 ipsla ipsla  9323 Nov  9  2018 main.c
-rw-r--r-- 1 ipsla ipsla  2587 Nov  9  2018 pak.c
-rw-r--r-- 1 ipsla ipsla   487 Nov  9  2018 responder.conf.sample
-rw-r--r-- 1 ipsla ipsla  4743 Nov  9  2018 responder.h
-rw-r--r-- 1 ipsla ipsla 33922 Nov  9  2018 test-main.c
-rw-r--r-- 1 ipsla ipsla  1920 Nov  9  2018 udp4.c
-rw-r--r-- 1 ipsla ipsla  1849 Nov  9  2018 udp6.c
-rw-r--r-- 1 ipsla ipsla  3020 Nov  9  2018 utils.c

But when i want to compile this, i get an error message:

root@srvmwips01:/# cd /tmp/ip-sla-responder-master/
root@srvmwips01:/tmp/ip-sla-responder-master# make CC=gcc
gcc -W -Wall -Wno-unused -Wno-unused-parameter -ggdb -O3 -DCONFIGFILE="\"/etc/responder.conf\"" -c -o utils.o utils.c
/bin/sh: 1: gcc: not found
make: *** [Makefile:27: utils.o] Error 127

I installed a fresh ubuntu LTS 20.04 but it doesnt seem to work. I installed followin tools in order to compile:

root@srvmwips01:/# apt install make
root@srvmwips01:/# apt install libpcap-dev

I already tried chown and chmod to make sure there is no permission problem. The manual says that i need some more things in order for the compile to work:

It needs pcap(3) interface on kernel and AF_PACKET. It also requires librt and libpcap.

But these packages are not available from apt install (anymore?). how do i get them? The libpcap i could find as a dev version. Not sure if this is the same, though. I read, that there is a prerequisit check command, that loads all the necessary modules from the apt store, but this only works for applications hosted up there. I downloaded my appliacation via github. I searched the site https://packages.ubuntu.com/ to find the libraries, but some searches come back with no results while others come back with a boat load of entries.

1

You're missing the GCC compiler and other libraries necessary for g++/gcc to compile things.

This is evidenced by your error message which is clear as day:

/bin/sh: 1: gcc: not found

Install build-essential with sudo apt install build-essential. This will pull in g++, gcc, and the core essential build libraries necessary to compile software.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.