1

Google has not really helped me to solve this problem, so I've come to the experts.

When my laptop springs back into life from going to sleep, the login screen comes up for the password and there is an overlay which indicates "touchpad off". I enter my password and login and yes my touchpad is not working, to fix this I have bound the following, xinput set-prop 10 "Device Enabled" 1, to the keystroke "ctrl +alt+P" and it works again.

Is it possible to run this automatically on wakeup/login so that I do not have to press the key combo?

Received a suggestion for a script as follows...

#!/bin/sh

if [ "${1}" = "pre" ]; then

not doing anything here…

elif [ "${1}" = "post" ]; then

enabling touchpad

xinput set-prop 10 "Device Enabled" 1

fi

Saved this to /lib/systemd/system-sleep/ and set it as executable.

This does not work, as this script seems to run successfully before the password is entered and screen is unlocked and I think the xinput command actually needs to be entered once unlocked and the gui/desktop has come back up.

The touchscreen works throughout this process with no similar issues.

I have examined the xorg, system and kernel logs and can see no errors that seem related to the touchpad.

Any suggestions on how to fix this gratefully received.

Many thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.