0

I have Dell Venue 11 tablet with original keyboard/touchpad. After installation of LUbuntu 20.04, sometimes it resumed from suspend by any key or touchpad, sometimes by openning the lid, which cause resuming in a bag due to vibration, overheating and switching off by thermal protection system. At the following link, there is dmesg output after resuming by openning the lid. It appears that there are lot of errors of mmc1 sdhci during suspend:

[https://drive.google.com/drive/folders/1fPSDkfeanu1c9SoKmRVrlERT5QyoxbQy?usp=sharing][1]

The tablet is configured to resume from suspend only by its power button (PNP0C0C:00).

/etc/rc.local:

#!/bin/bash
for f in /sys/bus/*/devices/*/power/wakeup
do
    echo disabled > $f
done
sleep 1
echo enabled > /sys/bus/acpi/devices/PNP0C0C:00/power/wakeup
echo enabled > /sys/bus/platform/devices/INT33D6:00/power/wakeup
echo enabled > /sys/bus/platform/devices/PNP0C0C:00/power/wakeup
exit 0

The configuration is recorded successfully:

:~$ for f in /sys/bus/*/devices/*/power/wakeup; do echo $f; cat $f; done
/sys/bus/acpi/devices/PNP0C0A:00/power/wakeup
disabled
/sys/bus/acpi/devices/PNP0C0A:01/power/wakeup
disabled
/sys/bus/acpi/devices/PNP0C0C:00/power/wakeup
enabled
/sys/bus/acpi/devices/PNP0C0D:00/power/wakeup
disabled
/sys/bus/pci/devices/0000:00:14.0/power/wakeup
disabled
/sys/bus/pci/devices/0000:00:16.0/power/wakeup
disabled
/sys/bus/pci/devices/0000:00:1b.0/power/wakeup
disabled
/sys/bus/pci/devices/0000:00:1c.0/power/wakeup
disabled
/sys/bus/pci/devices/0000:00:1c.3/power/wakeup
disabled
/sys/bus/pci/devices/0000:00:1f.2/power/wakeup
disabled
/sys/bus/pci/devices/0000:01:00.0/power/wakeup
disabled
/sys/bus/pci/devices/0000:02:00.0/power/wakeup
disabled
/sys/bus/platform/devices/alarmtimer.0.auto/power/wakeup
disabled
/sys/bus/platform/devices/INT33D6:00/power/wakeup
enabled
/sys/bus/platform/devices/PNP0C0C:00/power/wakeup
enabled
/sys/bus/platform/devices/PNP0C0D:00/power/wakeup
disabled
/sys/bus/pnp/devices/00:02/power/wakeup
disabled
/sys/bus/serio/devices/serio0/power/wakeup
disabled
/sys/bus/usb/devices/1-2.1.1.2/power/wakeup
disabled
/sys/bus/usb/devices/1-2.1.1.3/power/wakeup
disabled
/sys/bus/usb/devices/1-2.1.1/power/wakeup
disabled
/sys/bus/usb/devices/1-2.1/power/wakeup
disabled
/sys/bus/usb/devices/1-2/power/wakeup
disabled
/sys/bus/usb/devices/1-4/power/wakeup
disabled
/sys/bus/usb/devices/2-2.1.1.4/power/wakeup
disabled
/sys/bus/usb/devices/2-2.1.1/power/wakeup
disabled
/sys/bus/usb/devices/2-2.1/power/wakeup
disabled
/sys/bus/usb/devices/2-2/power/wakeup
disabled
/sys/bus/usb/devices/usb1/power/wakeup
disabled
/sys/bus/usb/devices/usb2/power/wakeup
disabled

I tried to disable INT33D6:00. After that, the system cannot be waked up.

How to configure the system to resume only by the power button?

  • Hibernate will do that. – C.S.Cameron Jun 30 at 8:39
  • Hibernation needs significant time for system snapshoting, but suspending is very quick. Resuming from hibernation sometimes causes blank screen without any reaction on keyboard or mouse. – v_mil Jun 30 at 15:50
0

Only one successful solution is unbinding USB controller before suspend. See answer 1 at How to set S3/S4 state for devices on suspend

It did not operate on LUbuntu 18.04 for me. But it successfully works on LUbuntu 20.04. In addition, it solves the problem with USB Ethernet controller, which could not restore the connection after resuming. There is only one minus - resuming needs approx. 4-5 s. for re-initializing USB (two USB hubs with a lot of periphery).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.