0

I'm still pretty green with Ubuntu, but I had previously configured backups from one Ubuntu Server on my network to another to add redundancy to my family's file storage. This worked very well, until the day I updated both servers to 20.04 LTS... and since then I can't get rid of the error "Storage location not available" on the origin server even though I can ping and map the target network share from any computer (Windows, Ubuntu or macOS) on my network.

I have made this share as wide open as possible (no credentials required) and I have gone so far as to reinstall the backup target host and reconfigure a new share, and it still gives me this error... if anyone can point me in the right direction I'd be grateful!

** As requested, from share host **

Output from: testparm -s


    Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

# Global parameters
[global]
    log file = /var/log/samba/log.%m
    logging = file
    map to guest = Bad User
    max log size = 1000
    obey pam restrictions = Yes
    pam password change = Yes
    panic action = /usr/share/samba/panic-action %d
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    passwd program = /usr/bin/passwd %u
    server role = standalone server
    server string = %h server (Samba, Ubuntu)
    unix password sync = Yes
    usershare allow guests = Yes
    idmap config * : backend = tdb


[printers]
    browseable = No
    comment = All Printers
    create mask = 0700
    path = /var/spool/samba
    printable = Yes


[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers

Output from: net usershare info --long

[plex]
path=/home/samba/plex
comment=
usershare_acl=Everyone:F,
guest_ok=y

contents of fstab on backup source host:

                                   
UUID=ee47a6bd-e854-4389-82f5-e806b8990cee / ext4 defaults 0 0
/swap.img       none    swap    sw      0       0
UUID=AE2E15562E151943 /media/plexfiles ntfs    defaults,nls=utf8,umask=000,uid=>

#mount remote plex backup share
//192.168.0.114/plex        /mnt/sharemount/      cifs     0       0

*** I have updated fstab under "#mount remote..." since the above with "rw,samba,username=$samba,password=$****" as seems appropriate, still not mounting as expected. I will have to check out the guides posted to see what I'm doing wrong.

Thanks everyone I feel like I'm getting close to a solution. I have jumped from place to place and skipped some replies, sorry about that... I am going through everything posted.

*** Referring to "man mount cifs" for info.

  • Could you specify when you receive the message? Which software do you use for backup? – Marc Vanhoomissen Jun 30 at 7:47
  • I have posted a basic answer, and want to reiterate to output the errors on the mount command for us. – DankyNanky Jun 30 at 12:20
  • In addition to the first comment please edit your question and add the output of the following commands from the server with the share: testparm -s and net usershare info --long. You say you can "map" the share from the other server. A true "map" in Linux is a cifs mount so we need to see how you are "mapping" it - the command you are using or the /etc/fstab entry. – Morbius1 Jun 30 at 13:46
  • In this case I was using \\file path on Windows Explorer, "connect to server" (finder+command+K) on Mac and "connect to server" in GNOME. I am getting the error when I click "Backup Now" in the "Backups" UI. I am proceeding with troubleshooting as suggested by DankyNanky,and yourself and I will write back when I have results... thanks very much! – kernel-sanders Jun 30 at 14:40
  • Your cifs mount will not work. You are missing a list of options: guest, and permissions or ownership settings. As it stands now it is syntactically incorrect. – Morbius1 Jun 30 at 15:25
0

First, it depends on how you are mapping the share you're attempting to backup to. For myself, I would create an entry in my fstab for permanent mounting, which can be done as follows:

# Example Comment on the Mount:
//192.168.0.121/myshare        /mnt/sharemount/      nfs     0       0

An example of my previous answer. You can read a better answer on directory structures if you want to know where you should mount things.

Then, it depends on how you're backing things up. If you're using inbuilt backup, set the destination to your location you have mounted and it "should just work".


Further to the error you're receiving - "Storage location not available" - this is very generic. From a terminal on the server, if you run the following command,the output should be quite explanatory of the error:

sudo mount -t nfs 10.x.y.z:/share /mnt/path -v

The -v will give you verbose output to let you know what's happening. For example, for me I get the following output on a successful mount:

mount.nfs: timeout set for Tue Jun 30 22:19:16 2020
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.0.121,clientaddr=192.168.0.116'

The type of share you're tying to mount will be dictated by the -t in the previous command; for me, a lazy person, I do a NFS mount and whitelist my IPs as read/write (not recommended), but you can start with this to see what errors you have

For a Samba Share, try the following command:

mount –t cifs IP_Address:/sharename /mountpoint –o username=userid,workgroup=workgroupname

Or for putting this in your fstab path:

# sudo nano etc/fstab

//10.x.y.z/share_file   /mount/pount    cifs  rw,user,username=$username,password=$password 0 0

Some other questions that you can refer to for Samba Diagnostics are:

  1. can't connecto to Samba Server on NAS
  2. Problem With Samba Share between Ubuntu 18.04 & Kali Linux
| improve this answer | |
  • 1
    Please edit your answer and replace "smbfs' with "cifs". smbfs was removed from the Linux kernel a decade or so ago. – Morbius1 Jun 30 at 13:49
  • Thanks very much for all this, I will be digging into it today. I realized this morning I should have tested Deja Dup against a different target on a different host before posting... I have now done so and it gave the same error message, even on a Windows share. This suggests that the issue may be on the backup source host, so I will have to look into that as well. – kernel-sanders Jun 30 at 14:04
  • Deja Dup is a graphical application. Are you running Ubuntu Server or Ubuntu Desktop as a server. – Morbius1 Jun 30 at 14:09
  • I am using Ubuntu Server with GNOME Desktop installed on both computers – kernel-sanders Jun 30 at 14:14
  • Question, should I be adding replies in comments or editing my original question above? – kernel-sanders Jun 30 at 14:54
0

Following Morbuis1's guidance I have updated my fstab file and now the remote filesystem is mounted upon boot, and backups are running again. I am going to make sure that I fully understand why this worked (I already have an idea) so that the next time I'm dealing with it I won't have to ask, and may be able to help someone else in the future.

contents of fstab as follows:

//192.168.0.114/plex        /mnt/sharemount/      cifs     guest,nounix,dir_mode=0777,file_mode=0666 0       0

Thanks to everyone who replied, this community is fantastic.

| improve this answer | |
New contributor
kernel-sanders is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • What you might want to do is copy my fstab suggestion ( or however you modified it ) into your answer so folks don't have to hunt for it. It's getting kind of crowded in here for me to post another formal answer. – Morbius1 Jul 1 at 18:22
  • Thanks, this is done. – kernel-sanders Jul 3 at 3:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.