1

I am new to this installing the 20.04 LTS server version on my computer, I am unable to boot from my USB to install the OS, I tried a lot of USB boot creators for this but nothing seems to work.

Every time I try a new boot creator I get new errors like, "bootmgr is missing", "failed to load ldlinux.c32", "Booting Kernel failed: invalid argument". I am feeling very disappointed because if I cannot even create a boot drive following the instructions in this ubuntu.com tutorial.

I don't know what else to do from here on out.

  • How did you create the USB? Did you md5sum hashcheck the downloaded iso file, and did you media check it afterward? Did you try the USB in a different USB port, and try it on another machine? – ubfan1 Jun 30 at 4:45
  • Did you write the correct architecture for your machine? or are you using a 32-bit only UEFI setup? Is this on real hardware? or a cloud service? (I see it also posted on news2.x-itm.com/failed-to-load-ldlinux-c32-on-ubuntu-20-04-lts where it's listed in cloud) – guiverc Jun 30 at 5:20
  • @ubfan1 I used rufus to create the USB, and I checked the md5sum hashcheck its ok. I only have one machine to test this on. – Killa Jun 30 at 9:01
  • @guiverc I am using this on a 64-bit, and this is on my desktop pc. – Killa Jun 30 at 9:03
  • When I need to make an Ubuntu USB from Windows, I use: linuxliveusb.com It has never failed me. Have you tried a desktop version to see if that boots? and make sure you get your ISOs from here: ubuntu.com/#download – Mark Kirby Jun 30 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.