I'm trying to install 12.04 amd64, but none of the options work. When the cd runs, the options to run,install,and check disk for defects give the following error: "/casper/vmlinuz: file not found". I've already checked the iso with md5sum. Any help would be greatly appreciated.

  • Hate to ask this, but could you try redownloading? That really seems like a major corruption issue. – Jjed Apr 26 '12 at 18:12
  • 1
    This sounds like a bad burn of the CD – Jorge Castro Apr 27 '12 at 3:42

Your right guys it was a bad burn. I made around 5 copies before, and all were bad. When i tried a different burner it worked. Thanks.


Simply delete the .efi extension. Worked for me!


  • How should I delete the .efi extension? I have the same problem, but it's on a live CD... no way to edit the contents.... – Bertvan Sep 27 '13 at 18:38
  • sorry, it's been a while since i did this... i believe i used a live USB rather than a CD for this very reason. perhaps it's possible to remove the .efi before you burn? – Ryan Sep 27 '13 at 19:37

For me I was installing Ubuntu Studio 17 on an older laptop and saw the error. What fixed it for me was to monitor the reboot and as SOON as I saw the select language area I pressed enter and then also selected the correct menu item to install the OS on the laptop. In my case it appears that the error was from the CD rom pausing and this causes the file read error. But if cd is still spinning, all is well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.