0

I had VirtualBox 6.0.4 and a Ubuntu 16.04 VM on my Win10 laptop.

Today, with help from an expert admin in my company who maintains the supported images, I upgraded this to VirtualBox 6.1.8 and Ubuntu 18.04.

What I'm left with after the upgrade are the following symptoms:

  • My shared folders are all empty
  • My window is tiny

I'm sure the reaction from most people would be that I haven't run the guest additions installer. However, I have run it, many times now. The output doesn't indicate any error at all, and the admin sees no issue with it.

What is curious is that after running the GA installer, when I bring up the Files dialog to eject the GA disk, it also has my shared folders mounted. When I eject the GA disk, the shared folders remain. However, when I restart the VM, I still have a small window and my shared folders are empty. The Files dialog no longer shows those mounts.

The output of the various ways of running the GA installer looks like this: Code:

VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel
modules. This may take a while. VirtualBox Guest Additions: To build modules for other installed kernels, run
VirtualBox Guest Additions: /sbin/rcvboxadd quicksetup <version>
VirtualBox Guest Additions: or VirtualBox Guest Additions: /sbin/rcvboxadd quicksetup all
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted

There are no obvious error messages that we can find.

0

There is no error message - that's the stdout you get from installing GA. Have you checked your shared folders are correctly mounted?
From host (MacOS in my example)

$ VBoxManage showvminfo mcs
<<snip>>
Shared folders:

Name: 'mcs', Host path: '/Volumes/WD4TB/mcs' (machine mapping), writable, auto-mount
Name: 'active', Host path: '/Volumes/WD4TB/mcs/complete' (machine mapping), writable, auto-mount
Name: 'archive', Host path: '/Volumes/My Book' (machine mapping), writable, auto-mount

On VM

sudo mount -o defaults,uid=1000,gid=$(getent group docker | cut -d: -f3) -t vboxsf mcs /media/sf_mcs
sudo mount -o defaults,uid=1000,gid=$(getent group docker | cut -d: -f3) -t vboxsf active /media/sf_active
sudo mount -o defaults,uid=1000,gid=$(getent group docker | cut -d: -f3) -t vboxsf archive /media/sf_archive
| improve this answer | |
  • The output from VBoxManage for the vm looks like your sample. What exactly is the intent and expected output from those commands on the VM? – David M. Karr Jun 30 at 15:30
  • I pasted how I mount named shared folder under /media. These mounts I re-establish on boot. mcs@mcs:~$ crontab -l @reboot $HOME/mediacentre/bin/reboot.sh mcs@mcs:~$ cat $HOME/mediacentre/bin/reboot.sh sudo mount -o defaults,uid=1000,gid=$(getent group docker | cut -d: -f3) -t vboxsf mcs /media/sf_mcs sudo mount -o defaults,uid=1000,gid=$(getent group docker | cut -d: -f3) -t vboxsf active /media/sf_active sudo mount -o defaults,uid=1000,gid=$(getent group docker | cut -d: -f3) -t vboxsf archive /media/sf_archive – Rob Raymond Jun 30 at 16:56
  • In my 16.04 VM, I never had to manually manage the mounts for shared folders in the VM, it just worked. I would also point out that I still have the small window, another indication that the GA is not working properly. However, I can also copy out of the VM window, which I believe is also something that the GA provides. – David M. Karr Jun 30 at 17:27
  • I'm using 20.04 and previously was using 19.10 (VBox 6.1+). I found that shared folders weren't auto mounting hence @reboot in crontab. On screen size, separate but I would guess it's the graphics controller setting - VMSVGA works for me. I normally use server build so no UI anyway. – Rob Raymond Jul 1 at 0:29
  • What user is that uid 1000 supposed to correspond to, and do you set this as the root crontab, or as a normal user? – David M. Karr Jul 1 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.