1

I have a dell optiplex 9010 desktop PC. I have just installed ubuntu 18.04, alongside windows 10, on my hard disc in a separate partition. All is ok except I cannot establish an internet connection. When I go onto settings> Wi-fi.....it says no wifi adapter found. I have tried running an ethernet cable from laptop to desktop but it will not establish a connection. I then tried tethering my mobile phone and this allowed me to go online however I still cant figure out how to install the drivers!!

Using my laptop (packard bell) I have looked online for the drivers for these devices only because I am assuming the device drivers are not present, I downloaded from an intel web site what I think are the related drivers. The name on the file to be extracted was e1000e-3.8.4.tar.gz. I have extracted these files to a usb stick but have no idea if 1) This is the probable fix and 2) if it is how can I upload these drivers to my desktop. (my desktop is an optiplex 9010)

I am very new to linux and following some suggestions online I used the terminal command 'lspci' and this showed the following what I believe to be wifi/ethernet related devices on the system:

  1. ethernet controller [0200]:intel corp 82579LM gigabit network connection. Subsystem: Dell 82579LM gigabit network connection. Kernel driver in use: e1000e. Kernel modules: e1000e
  2. ethernet controller [0200]:intel corp 82572EI gigabit ethernet controller. Subsystem: intel corp PRO/1000PT server adapter [8086:1082] Kernel driver in use: e1000e. Kernel modules: e1000e

I have two ethernet cards in my desktop.

  1. Intel PRO/1000PT server adapter 82572EI and...
  2. Intel 82579LM gigabit network connection...

Any help would be very much appreciated. Thanks in advance.

New contributor
zatta303 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • The e1000e module is provided with the standard repositories. Ensure your Dell firmware is up to date and look for "missing firmware" messages: dmesg |egrep -i "fw|firm" – ubfan1 Jun 29 at 17:48
  • Thank you for your response. I will check online how I can tell if the firmware is up to date or not. If honest I dont understand what 'standard respositories stand for/what they are but it has given me something to look into. – zatta303 Jun 29 at 18:56
  • I have not noticed any messages that relate to 'missing firmware' ...but I will look for them. When would these message likely occur? – zatta303 Jun 29 at 18:58
  • At power-on, the missing firmware messages wouild show up with in a few seconds. The e1000e module is present on my 20.04 Ubuntu, and I don't even have that hardware, so I doubt it's missing on your system. – ubfan1 Jun 29 at 19:00
  • Ok thank you. I will restart my system and look for messages in line with what you suggest. Appreciate your help. – zatta303 Jun 29 at 19:08

Your Answer

zatta303 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.