0

I run Ubuntu 18.04, kernel version: 5.3.0-59-generic. Recently kernel update 5.3.0-61-generic came out, but did not get successfully installed on my system. Since then, my NVIDIA driver is not working.

If I try installing either nvidia-driver-440 or nvidia-driver-435 using apt-get, it's successful but as I try to boot into the system, an error message shows: Failed to start Nvidia Persistence Daemon and the login screen doesn't show up. If I go into recovery mode and purge the nvidia drivers, I can boot fine.

I also tried installing the driver using a .run file. In that case, I'm able to see a login screen but I'm stuck in a login loop.

I think this is a kernel installation issue, since apt-get fails on 5.3.0-61-generic, and the error message shows :

update-initramfs: Generating /boot/initrd.img-5.3.0-61-generic
/etc/kernel/postinst.d/zz-update-grub:
grub-mkconfig: You must run this as root
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: error processing package linux-image-5.3.0-61-generic (--configure):
 installed linux-image-5.3.0-61-generic package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-image-5.3.0-61-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

When I'm already in root (I even tried sudo su, didn't help). So right now I'm stuck without GPU drivers on my system.

I'd really appreciate if someone could help me debug this problem. Thanks!

  • Boot your older kernel , install nvidia driver again(whatever you had before) , then run sudo dpkg --remove linux-image-5.3.0-61-generic && sudo update-grub , and after that you should be able to use your system just as before. – Parsa Mousavi Jun 29 at 12:56
0

I know about this everytime you install a new Kernel.

The best approach is to uninstall every Nvidia driver and related programs. Follow the instructions here: https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#removing-cuda-tk-and-driver

Then install it again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.