1

Want to control my fan speed. Tried pwmconfig but didn't work.

I get this

hwmon1/pwm3 is currently setup for automatic speed control

This one (hwmon1/pwm3) is my noise maker. Need it in manual mode, and also at the end of pwmconfig,configuration option is missing, I mean out of 5 option, I get only 4, also it seems /etc/fancontrol is emty.

edit-2

    sudo pwmconfig
[sudo] password for seebox: 
# pwmconfig version 3.6.0
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following devices:
   hwmon0 is coretemp
   hwmon1 is it8718

Found the following PWM controls:
   hwmon1/pwm1           current value: 254
   hwmon1/pwm2           current value: 254
   hwmon1/pwm3           current value: 254
hwmon1/pwm3 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) yes

Giving the fans some time to reach full speed...
Found the following fan sensors:
   hwmon1/fan1_input     current speed: 4218 RPM
   hwmon1/fan2_input     current speed: 0 ... skipping!

Warning!!! This program will stop your fans, one at a time,
for approximately 5 seconds each!!!
This may cause your processor temperature to rise!!!
If you do not want to do this hit control-C now!!!
Hit return to continue: 

Testing pwm control hwmon1/pwm1 ...
  hwmon1/fan1_input ... speed was 4218 now 3358
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon1/pwm1,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n

Testing pwm control hwmon1/pwm2 ...
  hwmon1/fan1_input ... speed was 4218 now 3169
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon1/pwm2,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n

Testing is complete.
Please verify that all fans have returned to their normal speed.

The fancontrol script can automatically respond to temperature changes
of your system by changing fanspeeds.
Do you want to set up its configuration file now (y)? y
What should be the path to your fancontrol config file (/etc/fancontrol)? 
Loading configuration from /etc/fancontrol ...

Select fan output to configure, or other action:
1) Change INTERVAL     3) Save and quit
2) Just quit           4) Show configuration

select (1-n):
8
  • post the output of pwmconfig in an edit.
    – rtaft
    Commented Jun 29, 2020 at 11:40
  • Oky ..............
    – Tanzin
    Commented Jun 29, 2020 at 14:11
  • I mean run pwmconfig, copy the output, edit this question, paste the output at the end, then select the output and press the {} Sample Code button and save it.
    – rtaft
    Commented Jun 29, 2020 at 15:28
  • Odd that it is not enabling pwm3 for testing. Can you manually set /sys/devices/platform/it8718/hwmon/hwmon1/pwm3_enable to 1 and then try it? Keep track of what it was set to before incase you need to revert it quick. Can then set /sys/devices/platform/it8718/hwmon/hwmon1/pwm3 to a value between 0-255 if its working. The path might need a little adjusting, just guessing from the info that is here.
    – rtaft
    Commented Jun 29, 2020 at 18:27
  • Also post the contents of /sys/devices/platform/it8718/hwmon/hwmon1/, you might be able to configure the bios settings for what temps and speeds it runs at.
    – rtaft
    Commented Jun 29, 2020 at 18:31

1 Answer 1

1

It looks like pwm3 is being skipped during the test. Try enabling it by editing the file /sys/devices/platform/it87.656/hwmon/hwmon1/pwm3_enable as root and set it's value to 1. Then run pwmconfig again. You can also manually set the fan speed by editing /sys/devices/platform/it87.656/hwmon/hwmon1/pwm3 and setting it to a value between 0-255.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .