1

I've been struggling to network my one Linux box (Ubuntu 18.04.4) with my Windows workgroup. Various things do work (see below), but nothing shows up under Windows Network in Ubuntu's file manager, and likewise the Ubuntu box does not show up on Windows. What crucial detail am I missing?

Ubuntu computer: Lenny, IP 192.168.0.61

  • There’s a shared Public folder, with All permissions for everyone.
  • Samba is running, with workgroup and public folder defined in smb.conf (testparm dump below).

Win10 computer: Tippy, IP 192.168.0.21

  • Network discovery and File/Printer sharing are turned on for Private networks.
  • Public folder sharing is turned on for All networks.
  • IIS is running.

Router: Host mapping is setup for Tippy and Lenny.

What Works:

  • Tippy or Lenny can ping each other by name or IP.
  • Web browser on Lenny can view pages on http://tippy
  • The Ubuntu remote desktop Remmina works fine, connecting to Tippy by name.

What Doesn’t Work:

  • Neither computer shows up in the other’s file manager, so I can’t see shared files.
  • If I try to navigate to \lenny or \lenny\public on Win10 it shows Error code 0x80004005 (Unspecified error). The Windows troubleshooter says the remote device won't accept the connection. I'm not clear on whether installing samba was even necessary. Some articles just say right-click a folder and set it as shared, but that by itself didn't work so I tried installing samba.

I think all I did to smb.conf was add the workgroup name and public folder. Here is testparm:

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
Processing section "[printers]"
Processing section "[print$]"
Processing section "[public]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

# Global parameters
[global]
    bind interfaces only = Yes
    dns proxy = No
    interfaces = 127.0.0.0/8 eth0
    log file = /var/log/samba/log.%m
    map to guest = Bad User
    max log size = 1000
    obey pam restrictions = Yes
    pam password change = Yes
    panic action = /usr/share/samba/panic-action %d
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    passwd program = /usr/bin/passwd %u
    server role = standalone server
    server string = %h server (Samba, Ubuntu)
    syslog = 0
    unix password sync = Yes
    usershare allow guests = Yes
    workgroup = CASTLE
    idmap config * : backend = tdb


[printers]
    browseable = No
    comment = All Printers
    create mask = 0700
    path = /var/spool/samba
    printable = Yes


[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers


[public]
    force create mode = 0777
    force directory mode = 0777
    force user = nobody
    guest ok = Yes
    guest only = Yes
    path = /samba/public
    read only = No
1

Your problems are all undoubtedly related to SMBv1, your Ubuntu machine will still be using it and the Win10 wont.This is further compounded by the fact that SMBv1 is needed for Network browsing, Windows has replaced Network browsing with Network discovery, but Linux doesn't use this, it uses Avahi instead. You can get a Linux Network discovery server here: https://github.com/christgau/wsdd

I would also suggest you turn off SMBv1 on your Ubuntu machine by adding these lines to your smb.conf file: client min protocol = SMB2_02 server min protocol = SMB2_02

| improve this answer | |
0

I would get out of the expectation of Linux hosts showing up under Network in Win10. When you move to Ubuntu 20 SMB1 will not be enabled on either the client or server side ( Just like Win10 ) and netbios browsing is dependent on it.

WSD will certainly work as a replacement.

Static ip addresses are also your friend here.

But so to is mDNS:

If I try to navigate to \lenny or \lenny\public on Win10 it shows Error code 0x80004005 (Unspecified error).

mDNS is available on WIn10 and Ubuntu so connect to the Linux machine that way:

\\lenny.local

IF successful you can "pin" it under Quick Access or your Start Menu.

Side note: I would remove the following lines from your smb.conf file and let samba figure this out on its own:

bind interfaces only = Yes
interfaces = 127.0.0.0/8 eth0

Then restart smbd.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.