1

I have been trying to use Xubuntu 20.04 in VirtualBox (host = Windows 10) and the bluetooth icon would not show up on the toolbar. The function also cannot be used even when it says that Bluetooth is active in the terminal.

I've tried several things that I could find on Google--including disabling bluetooth in Windows before launching VM and then enabling it--but seeing that I have basically zero knowledge on Linux I'm not even sure if they're worth mentioning. One thing that is strange to me is that when I start the virtual machine, when it asks me to either "Try Ubuntu" or "Install," bluetooth works every time when I just use the try option (but then the whole thing is too slow to do what I wanted to do). Once it's installed virtually, it stops working even when the bluetooth device is checked under USB.

Does anyone know why this is and if it's solvable? I'm not sure what other info to include but I will update if given some direction.

Thanks!!

[Update]

I think I did install the GA:

lsmod | grep vbox vboxsf 81920 0 vboxguest 348160 6 vboxsf

Also want to clarify that the bluetooth device is the laptop built-in device, not an USB adapter.

New contributor
Skypiea is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Have you tried other USB devices? Is Guest Additions installed on the VM? – ajgringo619 Jun 28 at 3:35
  • I tried using a flash drive, which worked fine and showed up as "attached USB device" alongside the bluetooth device; still no bluetooth icon though. I have the option to insert Guest Addition disc in the VM and I did, but nothing happens and I'm assuming it's installed... – Skypiea Jun 29 at 1:00
  • Make sure that GA is installed; I don't think you can use USB3 without it. – ajgringo619 Jun 29 at 1:02

Your Answer

Skypiea is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.