6

I just upgrade from 18.04 to 20.04, and I have a problem with my docks icons. The problem is the dock is not updating itself.

  • If I open an app, it won't show.
  • If I close an app, it won't go away
  • If I change from a virtual desktop to another (I have independent virtual desktops since 16.04), I'll continue seeing the icons from the previous one (the little dots showing how many windows are opened on a desktop do update tho).

The only way to update the dock is by changing the icons theme appearance on Tweaks, but I have to shange it every time I open or close an app or everytime I change from one virtual desktop to another.

On some other posts they say the problem fixes when setting the theme to default, but no theme worked for me.

what could it be? how could I fix it?

Thank you!


Here is a video of the problem.

Note that I have activated long ago the isolate-workspaces setting with gsettings set org.gnome.shell.extensions.dash-to-dock isolate-workspaces true please note that the dock updates the icons whenever I change the icons theme on tweaks. There is some point at 0:54 where the dock updates itself by its own, but this happens once in a while, not always as it should happen.

https://drive.google.com/file/d/1DHJlnF-W_J6PRp6SZNl8AxNd1EbmTRFz/view?usp=sharing

(I want to apology for the typos, english is not my native language and I was on a hurry, just now I watched it and noticed them)

7
  • 1
    Have you tried sudo update-icon-caches /usr/share/icons/* ? – Momo Jun 27 '20 at 23:33
  • @pomsky, point one is consistent with point two thanks to what's written just below the three points. The dock updates itself if I change the icons theme with teams. I'll improve my redaction. – JPabloFuenzalida Jun 28 '20 at 2:19
  • @pomsky thanks for your help, but I did that config long ago. I just did it again, but nothing changed. As how I see it, the dock is just not updating itself propperly. I'll post a video on the original post, but it might (It might take some time due to slow internet connection) – JPabloFuenzalida Jun 28 '20 at 18:28
  • The issue is already answered here askubuntu.com/questions/1230778/… – pernpas Jul 18 '20 at 11:26
  • 1
    Upgraded from 18.04.4 to 20.04.1 today and I'm seeing the same issue, which the answer linked by @pernpas did not resolve – Sam Estep Aug 7 '20 at 3:35
4

I had the exact same problem, so I investigated.

The root cause is a JS error in /usr/share/gnome-shell/extensions/ubuntu-dock@ubuntu.com/dash.js: JS ERROR: TypeError: firstIcon is undefined (can be seen in journalctl /usr/bin/gnome-shell -f).

I edited the file in-place to make sure this was indeed the problem, and replaced:

        let firstIcon = firstButton.icon;
        
        // Enforce the current icon size during the size request
        firstIcon.setIconSize(this.iconSize);

with

        let firstIcon = firstButton.icon;
        
        // Enforce the current icon size during the size request
        if (firstIcon) {
            firstIcon.setIconSize(this.iconSize);
        }

ensuring that the execution is not stopped if firstIcon is undefined. Then I reloaded the gnome shell using Alt+F2 then r, and lo and behold, the issue was gone!

I haven't investigated the reason why firstIcon was null to begin with. Therefore, I don't know if I have corrected the issue or just one of its symptoms, so I'm not sure if this should be turned into a PR or just a documented bug-report.

2
  • 1
    Thanks, this resolved my problem! Looks like this was resolved (in a slightly different way) in the Ubuntu Dock source, but isn't in the version released with 20.04. – GalacticCowboy Oct 7 '20 at 20:21
  • You saved me! Many Thanks!! – JKHA Oct 25 '20 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.