1

I'm using Ubuntu 18.04 and after update to the latest kernel I can't seem to disable my laptop from going to sleep after a few minutes, even though sleep mode is disabled already. It even goes to sleep when I'm watching a movie, it's annoying.

Here's screenshot of my power setting

enter image description here

I also follow some instructions from : How do I disable my system from going to sleep? to execute :

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Still not working, my laptop still goes to sleep mode. I've also tried

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout '0' 
&& gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout '0'

But my laptop still goes to sleep. I also came across suggestion to add acpi=off in GRUB setting but then I also read it can lead to many other effects. Literally a few minutes ago it went to sleep that's why I remember to post it here.Any advice ?

1 Answer 1

1

If you're using gnome, you can use dconf-editor. You can install it via apt.

For me, it was a similar setting: /org/gnome/settings-daemon/plugins/power/sleep-inactive-ac-type

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.