0

I am having HP laptop (Hp 15R250Tu) with Realtek RTL8723BE WIFI card. The WIFI connection keeps getting Dropped after some time like 15-20 minutes and then it won't connect no matter what I do expect the only option left is to restart. To solve this I tried several solutions but NO Success. After trying this solutions I am getting WIFI-Adapter not found and its Not getting connected. I don't know whether I messed up with my WIFI drivers. I am left further with No Clue what shall be done. Please any help would be appreciated.

Solutions tried up till now:

realtek-rtl8723be-wifi-drivers-not-working-after-upgrading-to-5-4-0-37

realtek-rtl8723be-wi-fi-incredibly-weak

how-to-permanently-install-wifi-driver-realtek-8723de-in-ubuntu-18-04

wifi-signal-is-weak-in-ubuntu-18-04-with-rtl8723be

wifi-networks-not-found-ubuntu-18-04-with-rtl8723be

how-do-i-get-a-realtek-rtl8723be-wireless-card-to-work

unable-to-connect-wifi-ubuntu-14-04-lts-hp-pavilion-network-driver-rtl8723be

Edit 1: As per comments dkms status

fwts-efi-runtime-dkms, 18.03.00, 5.3.0-59-generic, x86_64: installed
fwts-efi-runtime-dkms, 18.03.00, 5.3.0-61-generic, x86_64: installed
rtlwifi-new, 0.10: added
rtlwifi-new, 0.6, 5.3.0-59-generic, x86_64: installed (WARNING! Diff between built and installed module!)

dmesg | grep -i rtl

[    4.660507] r8169 0000:04:00.0 eth0: RTL8106e, 5c:b9:01:f9:a3:62, XID 449, IRQ 93
[   29.093217] Bluetooth: hci0: RTL: HCI_OP_READ_LOCAL_VERSION failed (-110)
[   50.560829] RTL8208 Fast Ethernet r8169-400:00: attached PHY driver [RTL8208 Fast Ethernet] (mii_bus:phy_addr=r8169-400:00, irq=IGNORE)

rfkill list

0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no

Edit 2:

  1. Output of lspci -knn | grep Net -A3; rfkill list

    0: hci0: Bluetooth Soft blocked: yes Hard blocked: no

  2. Output of dmesg | grep -i rtl

    [ 4.666458] r8169 0000:04:00.0 eth0: RTL8106e, 5c:b9:01:f9:a3:62, XID 449, IRQ 93

    [ 18.379865] Bluetooth: hci0: RTL: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723

    [ 18.381299] Bluetooth: hci0: RTL: rom_version status=0 version=1

    [ 18.381305] Bluetooth: hci0: RTL: rtl: loading rtl_bt/rtl8723b_fw.bin

    [ 20.016261] Bluetooth: hci0: RTL: rtl: loading rtl_bt/rtl8723b_config.bin

    [ 20.016311] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2

    [ 20.016327] Bluetooth: hci0: RTL: cfg_sz -2, total sz 22496

    [ 49.864307] RTL8208 Fast Ethernet r8169-400:00: attached PHY driver [RTL8208 Fast Ethernet] (mii_bus:phy_addr=r8169-400:00, irq=IGNORE)

3
  • Please don't post screenshots of text. Anyway all is looking good there. What is the kernel version uname -a?
    – Pilot6
    Commented Jun 27, 2020 at 7:26
  • Ok I'll remember from next time @Pilot6 Even I followed your previous answers. Kernel Version is 5.3.0-61 updated yesterday.
    – Tushar
    Commented Jun 27, 2020 at 8:17
  • Please add output AS TEXT of dkms status and dmesg | grep -i rtl and rfkill list
    – Pilot6
    Commented Jun 27, 2020 at 8:21

1 Answer 1

0

Remove rtlwifi_new modules. They are not needed with the 5.3 kernel. Run in a terminal:

sudo dkms remove rtlwifi-new/0.10 --all
sudo dkms remove rtlwifi-new/0.6 --all

and reboot.

6
  • Followed the commands and rebooted nothing is shown up still Wifi adapter not found.
    – Tushar
    Commented Jun 27, 2020 at 9:02
  • Please add output of lspci -knn | grep Net -A3; rfkill list and dmesg | grep -i rtl.
    – Pilot6
    Commented Jun 27, 2020 at 9:03
  • I have updated the post with the outputs
    – Tushar
    Commented Jun 27, 2020 at 9:45
  • Can you format text properly? It is unreadable. I don't see any wireless adapters now. The device is disabled in BIOS or broken.
    – Pilot6
    Commented Jun 27, 2020 at 9:47
  • Sorry Sir I edited it but don't know why the changes was not visible I have edited once again.
    – Tushar
    Commented Jun 27, 2020 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .