I try to install an advanced print-driver for Kyocera TASKalfa 3252ci.

The Problem is that python-reportlab is not installable for Ubuntu 20.04 LTS.

There is only python3-reportlab but this is not working with that print-driver.

Also python-is-python2 and python-is-python3 are not working.

Is there a possibility to fix this problem?


$ sudo dpkg -i kyodialog_5.0-0_amd64.deb 

(Reading database ... 275586 files and directories currently installed.)
Preparing to unpack kyodialog_5.0-0_amd64.deb ...
Unpacking kyodialog (5.0-0) over (5.0-0) ...
dpkg: dependency problems prevent configuration of kyodialog:
 kyodialog depends on python; however:
  Package python is not installed.
 kyodialog depends on python-reportlab; however:
  Package python-reportlab is not installed.

dpkg: error processing package kyodialog (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Errors were encountered while processing:
  • If your driver won't work with python3-reportlab then you could look for newer driver. Failing that you could install python-is-python2, then get these 2 packages, packages.ubuntu.com/eoan-updates/python-reportlab & packages.ubuntu.com/eoan-updates/python-reportlab-accel Then install both together with apt. Ex. - sudo apt install ~/Downloads/python-reportlab_3.5.23-1ubuntu0.1_all.deb ~/Downloads/python-reportlab-accel_3.5.23-1ubuntu0.1_amd64.deb Or go back to 18.04..
    – doug
    Jun 27, 2020 at 2:53
  • Many thanks. It worked to install python-reportlab on Ubuntu 20.04.
    – Stefan R
    Jun 27, 2020 at 9:13

1 Answer 1


Many thanks. Solved the problem.

sudo apt-get install python-is-python2

Download python-reportlab & python-reportlab-accel

wget http://de.archive.ubuntu.com/ubuntu/pool/universe/p/python-reportlab/python-reportlab_3.5.23-1ubuntu0.1_all.deb

wget http://de.archive.ubuntu.com/ubuntu/pool/universe/p/python-reportlab/python-reportlab-accel_3.5.23-1ubuntu0.1_amd64.deb

sudo apt install ./python-reportlab_3.5.23-1ubuntu0.1_all.deb ./python-reportlab-accel_3.5.23-1ubuntu0.1_amd64.deb

Now it was possible to install the driver.

  • I tried to download python-reportlab_3.5.23-1ubuntu0.1_all.deb and python-reportlab-accel_3.5.23-1ubuntu0.1_amd64.deb but under the given links the files are not to be found Dec 17, 2020 at 16:49
  • 2
    Files are available here: launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/… Feb 16, 2021 at 17:49
  • Thanks a lot! I was mistakenly running dpkg -i instead of apt install on the downloaded debs. Does anybody know the difference ?
    – antoniom
    Sep 13, 2021 at 16:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .