I don't have permission to cd into my own external hard drive. sudo cd is not a syntactically legal command (tried it). What is going on?

  • 1
    Could you please edit your post to include the output of groups? It would be helpful to know if you're in the media group, specifically.
    – earthmeLon
    Jun 26, 2020 at 18:51
  • 1
    if gaining root permission is issue you can do sudo su[ENTER], give passwd and you will have permission. Also have you tried browsing cd from graphical file manager? Jun 26, 2020 at 18:51
  • 1
    Try using pmount or mounting through Nautilus (gvfs-mount) so the media gets mounted with different ownership.
    – user535733
    Jun 26, 2020 at 18:52
  • 1
    Okay I figured it out. For some reason there are two mount points in /media/[etc], [name of external] and [name of external]1. This also shows up in Nautilus. [name of external] doesn't lead anywhere, but all my files are on [name of external]1, both in Nautilus on in terminal, and I do have cd permission for that file path. It's strange, but technically not broken? Jun 30, 2020 at 22:28
  • I got exactly the same issue...and thanks to your question and comment I solved it.
    – fabien7474
    Jun 2, 2021 at 8:24


You must log in to answer this question.

Browse other questions tagged .