1

Ubuntu 20.04. I have a new 32gb usb drive and I cannot copy more than roughly 200mb on it. It then tries to copy more but cannot and I cannot cancel anything. I am forced to remove the device.

I tried formatting it with the disk utility and gparted. I have used fat, ntfs and ext4 type of partition.

From suggestion from this site, I also tried dd and mkusb. Each time it shows that the volume is 32gb and it works correctly.

Is there any tool that would help me fix this drive?

Edit 1: So I tried the f3probe and here is the output:

Good news: The device `/dev/sdc' is the real thing

Device geometry:
             *Usable* size: 28.91 GB (60628992 blocks)
            Announced size: 28.91 GB (60628992 blocks)
                    Module: 32.00 GB (2^35 Bytes)
    Approximate cache size: 0.00 Byte (0 blocks), need-reset=no
       Physical block size: 512.00 Byte (2^9 Bytes)

Probe time: 13'40"
 Operation: total time / count = avg time
      Read: 424.7ms / 4815 = 88us
     Write: 13'38" / 4192321 = 195us
     Reset: 0us / 1 = 0us

So it seems genuine. As for speed test of writing, it seems ok as long as the sample are small, for example:

sudo dd if=/dev/zero of=/dev/sdc bs=1M count=25
25+0 enregistrements lus
25+0 enregistrements écrits
26214400 octets (26 MB, 25 MiB) copiés, 13,0983 s, 2,0 MB/s

but I ran a sudo dd if=/dev/zero of=/dev/sdc bs=1M count=50 and I waited 30min before unpluging it, because it was stucked.

As for the reading :

sudo dd if=/dev/sdc of=/dev/null bs=1M count=1024
1024+0 enregistrements lus
1024+0 enregistrements écrits
1073741824 octets (1,1 GB, 1,0 GiB) copiés, 54,0052 s, 19,9 MB/s

So it seems that the drive is actually broken, it is surprising because I bought a pack of 3 and all 3 are broken the same way. It is also a fairly known brand: Philips. I will see to get refund or replacement.

Thank you for your help

2
  • use software to detect fake usbs
    – Ferroao
    Jun 26 '20 at 18:24
  • It may be a very slow drive? What is the performance (MBytes/sec) when you do a dd on the device? Check the read and write performance separately. Jun 26 '20 at 18:25
1

There are falsified USB drives in the market, where people take drives with a small capacity and manipulate them, so the drives seemingly have a larger capacity. There's a similar scam with micro SD cards. If you happen to speak German, the tech magazine c't has published multiple articles on the topic.

But your drive is probably too small to be one of those. Those falsified USB drives are often drives that actually have 32 GB and are marked as having 1 TB or more. So, I wouldn't rule out that you caught a lemon, and the drive is just broken. Maybe you can return it.

You could test the drive with the command line software f3. This tool writes random data to the drive, and then checks whether it can read the same data back - meaning, whether the drive actually stored the data. f3 is in the Ubuntu repositories, so you can just install it with apt.

For a quick test, check which device file corresponds to the unmounted(!) drive. That should be something like /dev/sdb, /dev/sdg or similar. Then do

sudo f3probe --destructive --time-ops /dev/sdb

Warning: This will erase any data that may be on the drive before the test.

Further information about the tool can be found in the f3 documentation.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.