I have a USB switch with a keyboard and mouse plugged into it. It works fine on my Windows machines. When I boot into Ubuntu with the switch connected to the Ubuntu machine and the Ubuntu machine selected, the mouse and keyboard work fine. When I select one of the other machines on the USB switch and then subsequently select the Ubuntu machine again, the keyboard and mouse no longer work.

I ran a simpler experiment by just plugging the mouse directly into the Ubuntu machine, and I observed similar behavior. When the machine first boots up, the mouse works fine. I then tried unplugging the mouse and plugging it back in, and the mouse stopped working. I've tried this with two different mouses, and they both have this problem. The USB switch, mouses, and keyboard work fine on my Windows machines.

This problem occurred in Ubuntu 18.04, so I tried upgrading to 20.04. I am having the problem in 20.04, also.

Update: On the machine running Ubuntu, the USB switch works fine in BIOS (I can select and deselect the machine from the switch, and the mouse and keyboard still work). This suggests that the problem is not hardware-related.

Also, while in Ubuntu, I tried plugging in a USB drive. It works when I first plug it in, but if I unplug it and plug it back in, Ubuntu doesn't detect it.

Update: I've observed that if I "suspend" the machine (through the "Power Off/Logout" menu), and then deselect/select the Ubuntu machine through the USB switch, the mouse and keyboard start working again, until I deselect the machine again. In other words, in order to select the Ubuntu machine though the USB switch, I either have to reboot the machine or suspend it.

1 Answer 1


I had similar error on Ubuntu 20.04 and I disabled usb autosuspend and now it is working for me.

I used the following article: https://www.makeuseof.com/tag/fix-usb-device-port-linux/#restarting-linux-to-fix-a-usb-port


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .