I'm following the upgrade instructions on Ubuntu's website, but on launching the upgrade tool I get this response:

Checking for a new ubuntu release
No new release found

Am I doing something wrong? Is there a workaround?

  • Strangely, it is also possible to get this message when there is no internet connection, e.g. when networking is down. For some reason no error message is shown in such cases. – jotik Aug 24 '19 at 8:45

According to Ubuntu Engineering Foundations team manager Steve Langasek:

Upgrades between LTS releases are not enabled by default until the first point release, 14.04.1, scheduled for July. It is recommended that most LTS users wait until then before upgrading to 14.04.

If you choose to upgrade before then, you can pass the -d option to the upgrade tool, running do-release-upgrade -d or update-manager -d, to upgrade from vanilla 12.04 to 14.04. (-d stands for devel.)

This question explains the justification for waiting for the prompt:

| improve this answer | |
  • 14
    Why, then, is do-release-upgrade (without the -d) still saying "No new release found" a few days after the .1 has been released in iso form? (My /etc/update-manager/release-upgrades says "Prompt=lts") – tu-Reinstate Monica-dor duh Aug 1 '14 at 1:00
  • 8
    From an inspection of the code, it seems that "normal" releases default to a URL changelogs.ubuntu.com/meta-release which lists 14.04, and LTS releases use the URL changelogs.ubuntu.com/meta-release-lts which doesn't list it at all. I think they haven't updated the meta information yet. – tu-Reinstate Monica-dor duh Aug 1 '14 at 1:28
  • 3
    That seems like a release oversight, can you file a bug and CC me? email is in my profile, thanks! – Jorge Castro Aug 1 '14 at 3:20
  • 2
    @JorgeCastro Is this indeed a release oversight, and is there any idea when it will be fixe? Was a bug filed, and where can I follow it? (I searched, but could not find it. I also want to switch from 12.04 LTS to 14.04.1 LTS, and I just want to do it through the Update Manager.) – MarnixKlooster ReinstateMonica Aug 9 '14 at 7:12
  • 1
    Looks like changelogs.ubuntu.com/meta-release-lts is fixed now. – DLosc Aug 11 '14 at 20:52

If one has no access to a GUI and wants the update on terminal:

  1. Edit the file


    for Prompt to match either normal or lts. (See list below what fits your case, be aware that you can only upgrade an LTS to another LTS version):

  2. Test correct version is found, run

    do-release-upgrade -c
  3. Upgrade in case correct version is shown:

    sudo do-release-upgrade

    If you want to upgrade to development state (e.g. if you want to go from 18.10 to 19.04 before its official release) the -d flag is helpful:

    sudo do-release-upgrade -d

That way I could upgrade a 12.04 to 12.10.

The available Prompt options are:

  • never - Never check for a new release.
  • normal - Check to see if a new release is available. If more than one new release is found, the release upgrader will attempt to upgrade to the release that immediately succeeds the currently-running release.
  • lts - Check to see if a new LTS release is available. The upgrader will attempt to upgrade to the first LTS release available after the currently-running one. Note that this option should not be used if the currently-running release is not itself an LTS release, since in that case the upgrader won't be able to determine if a newer release is available.
| improve this answer | |
  • 3
    I had a similar issue. I simply changed from Prompt=normal to Prompt=lts and it worked just fine for me. – sir_k Sep 9 '14 at 10:48
  • I found the opposite problem to what Florin describes. On 4-21-18, Ubuntu 14.04 LTS was saying 'No new release found' until I changed from 'Prompt=lts' to 'Prompt=normal'. It picked 16.04 LTS to upgrade to, which is what I wanted. I have no idea why. – Winter Dragoness Apr 21 '18 at 20:03
sudo do-release-upgrade -d 

Notice the -d at the end; from the man page:

  -d, --devel-release
      If using the latest supported release, upgrade to the development release

This works even with Prompt=lts in /etc/update-manager/release-upgrades.

| improve this answer | |
  • the same as was described in the question... – antivirtel May 17 '15 at 11:07

2 options :

  1. Burn the iso and put it in your drive, it will detect the upgrade automatically

  2. Go in you synaptics options, then Preference > distribution > Always prefer the highest version.

Problem solved ?

| improve this answer | |
  • Will try this, thanks. :) I feel stupid for not realising that. – CullenDM Apr 28 '12 at 2:16
  • 1
    10.04 releases won't upgrade right away, see the link I posted above. – Jorge Castro Apr 28 '12 at 2:18

In case you are having this issue and it's not the 18.04.1 problem or and switching to lts or non-lts updates changes nothing, try the following (super hard to find steps).

Open a terminal and type: export DEBUG_UPDATE_MANAGER=true before the do-release-update -c command to see what goes wrong.

If you are getting the problem I have:

result of meta-release download: '<urlopen error timed out>'
NO self.metarelease_information
No new release found.

You could be facing the issue that you have a proxy configured for apt that is no longer relevant. Because of historic reasons (bug #446552), there are several unreasonable places where the updater will look for proxy settings. Beside the system-wide settings you should also check bash environment variables, gconf gnome proxy settings, /etc/apt/apt.conf and in my case /root/.synaptic/synaptic.conf.

The latter mind you no longer has a working menu in the GUI and the only way to remove the proxy settings is to edit the file. You can also just remove the file, that also works.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.