1

I tried asking this earlier, but my problem still persists.

I'm running Brave Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit) on my 19.10 Ubuntu laptop.

If I run sudo apt-get update I get the following failures:

Get:13 https://brave-browser-apt-release.s3.brave.com eoan InRelease [3,162 B]                           
Hit:14 http://ppa.launchpad.net/system76/pop/ubuntu eoan InRelease
Err:15 http://ppa.launchpad.net/ian-berke/ppa-drawers/ubuntu eoan Release
  404  Not Found [IP: 2001:67c:1560:8008::15 80]
Err:13 https://brave-browser-apt-release.s3.brave.com eoan InRelease
  The following signatures were invalid: EXPKEYSIG A8580BDC82D3DC6C Brave Software <support@brave.com>
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/ian-berke/ppa-drawers/ubuntu eoan Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://brave-browser-apt-release.s3.brave.com eoan InRelease: The following signatures were invalid: EXPKEYSIG A8580BDC82D3DC6C Brave Software <support@brave.com>

If I click on the link, I don't see an eoan release, but I do see the xenial release on 2016-May-04. What file should I edit to tell Ubuntu to use that release?

One of the references to my previous attempt suggested that I install ppa-purge. I did, but no joy.

I'm lost on how to solve my specific problem. I'd like to update Brave. I'm sorry to not know better, but I'd appreciate advice on a specific corrective action to take.

i tried removing Brave completely:

sudo apt remove brave-browser
sudo apt purge brave-browser
rm -rf ~/.config/BraveSoftware
rm -rf ~/.cache/BraveSoftware

I thought this would solve the problem. But I still get that same error when I execute sudo apt-get update.

I see that Ubuntu 19.10 reaches the end of its life next month. Is the answer to upgrade to 20.10 and try again?

4
  • By opening the link in your error (ppa.launchpad.net/ian-berke/ppa-drawers/ubuntu/dists) you can quickly see the release it supports.. or better yet before adding view the details launchpad.net/~ian-berke/+archive/ubuntu/ppa-drawers where it's pretty easy to spot 2016 was the last update; why add it when it won't have any support for any release after that (ie. 19.10). You also mention 20.10? that comes out in October (why it's 20.10; 2020-October using the yy.mm format of Ubuntu releases), 19.10 upgrades to 20.04 LTS not to 20.10 – guiverc Jun 26 '20 at 1:37
  • I get 404 from that link. – duffymo Jun 26 '20 at 1:40
  • What I really want is updates to Brave. Possible to uninstall and reinstall? linuxmadesimple.info/2019/10/… – duffymo Jun 26 '20 at 1:41
  • I've updated my question with more details. Please advise. – duffymo Jun 26 '20 at 2:03
2

Remove the obsolote repository.

sudo add-apt-repository --remove ppa:ian-berke/ppa-drawers

Fetch newest Brave Browser's key.

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

Update the index repository, try installing brave once again.

sudo apt update
sudo apt install brave-browser
1
  • I would award you 1,000 points if I could. This was the fix. Thank you so much for your generous help. – duffymo Jun 26 '20 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.