1

This is a virgin install of 20.04, not upgrading from 18.04 and previous versions. I tried to add an item to Other using MenuLibre. Launcher tested OK, saved, etc., yet Whisker menu still not showing "Other" category. If I go back to MenuLibre it does not even show my addition. Yet, in my $HOME all changes and the launcher file is created. I researched the subject, consulted answer here "How to reset MenuLibre"; purged, deleted related files, reinstalled MenuLibre, but nothing helps. This really baffles me.

Further notes a few days later: After various attempts finally I have the "Other" category in Whisker menu with my custom added menu items (launchers). However, I had to do it "under the hood" and not with MenuLibre. Here is how:

  1. deleted ~/.config/menus/applications-merged and ~/.config/menus/gnome-applications-merged folders
  2. created my launchers (.desktop files) in ~/.local/share/applications/ with Mousepad, according to relevant specs
  3. edited ~/.config/menus/xfce-applications.menu XML file with Mousepad in the <Name>Other</Name> section within <layout> part by adding there <Filename>MyOwnLauncher.desktop</Filename> lines of my own Other menu items.

This seems to work. Maybe tedious, but not as frustrating as MenuLibre. I even created a new user to see if MenuLibre would work there - but not really. Same thing, Other is not shown. The new menu item in the other category is in fact created in ~/.config/menus/applications-merged as .desktop files, but invisible to Whisker menu.

Could this be a bug in MenuLibre for the 20.04 xUbuntu version?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.