4

On my PC, inside gnome-terminal in Ubuntu 18.04, the bell sound plays just fine when I run this:

echo -e "\a"

However, in the terminator terminal (sudo apt install terminator), which I now use as default because it has beautiful screen windowing abilities, it won't play the sound! Why not?


NOT A DUPLICATE: This is not a duplicate of other Questions, such as this one (Beep in shell script not working?), because I am asking specifically about the terminator terminal. My bell sound works fine in other terminals, for instance, but not in terminator. This is a new, unique question.

1 Answer 1

5

It turns out you just have to enable the setting! (It comes disabled by default).

Right-click on the terminator screen --> Preferences --> click the "Profiles" tab at the top --> ensure the "General" sub-tab is chosen --> check the box for "Audible beep" under the "Terminal bell" section in the bottom-right:

enter image description here

That's it! Works perfectly now--same as in gnome-terminal, even over ssh:

echo -e "\a"

Related:

  1. Beep in shell script not working?
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .