1

I'm a complete linux newbie and have just installed Ubuntu 20.04. In my prior OS windows, I was using Foobar2000 and was able to play DSD files natively. The DAC would display a change in the sample rate with different tracks. Now instead it sticks at 48000 PCM regardless of what I am playing and when I play my DSD files, it plays it at 48000. How do I get my DAC to play DSD natively again ?

lsusb : Bus 001 Device 005: ID 152a:8750 Thesycon Systemsoftware & Consulting GmbH D10

aplay -l :
 **** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: D10 [D10], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Please let me know if more information is required from me. Thank you.

2
  • If you are using the default Ubuntu configuration, then it's likely that PulseAudio uses a common sample rate in order to be able to mix multiple streams together. – CL. Jun 24 '20 at 20:39
  • Hi , thanks for the reply, I was 'sort of' able to resolve it. I ended up using MDP/NCMPCPP to play all my audio files. What i had to do was to ammend the mdp.conf file to allow it to play variable sample rates. Still works at a constant 44.1khz for everything else. The following was what i changed in the .conf file : – beherit Jun 26 '20 at 0:20
1

thanks for the reply, I was 'sort of' able to resolve it. I ended up using MDP/NCMPCPP to play all my audio files. What i had to do was to ammend the mdp.conf file to allow it to play variable sample rates (Audio Output {...format "::*"} ) Still works at a constant 44.1khz for everything else.

As the following :

audio_output {

type "alsa"

name "USB DAC Topping D10"

device "hw:1,0"

mixer_type "hardware"

mixer_control "DIGITAL"

auto_resample "no"

auto_format "no"

enabled "yes"

format "::*"

}

Sourced the solution from the MDP wiki/documentation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.