6

I've dual booted my windows 10 laptop. After installing UBUNTU 20.04 LTS, it can't detect the NVIDIA driver. Though, windows os still detects the driver. I've installed nvidia driver, but it's not detected.

I've tried sudo ubuntu-drivers devices. It doesn't show anything. At Additional driver section in Software & updates apps,

No additional drivers available

is shown.

All in all, UBUNTU 20.04 LTS isn't detecting the NVIDIA driver for unknown reasons. Please, help me out.

My NVIDIA Graphics card: Geforce 820M

I've attached the output of lspci -k | grep -EA3 'VGA|3D|Display'

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
    Subsystem: Hewlett-Packard Company HD Graphics 5500
    Kernel driver in use: i915
    Kernel modules: i915
--
09:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
    Subsystem: Hewlett-Packard Company GeForce 820M
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
0a:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
11
  • 1
    Please edit your question and add output of lspci -k | grep -EA3 'VGA|3D|Display' terminal command.
    – Pilot6
    Commented Jun 23, 2020 at 16:14
  • It looks like the driver is installed, but not loaded. Is Secure Boot disabled in BIOS?
    – Pilot6
    Commented Jun 23, 2020 at 16:58
  • 1
    What does prime-select query show?
    – Pilot6
    Commented Jun 23, 2020 at 17:18
  • 1
    And also sudo modprobe nvidia.
    – Pilot6
    Commented Jun 23, 2020 at 17:18
  • 1
    Please run sudo apt install --reinstall nvidia-driver-440 and post the output to your question.
    – Pilot6
    Commented Jun 23, 2020 at 17:24

6 Answers 6

9

I just had a similar situation with Nvidia driver not being recognized. Thanks to an answer to a similar complaint I did the following procedure to fresh install the Nvidia drivers:

sudo apt-get install nvidia-driver-440

Due to the number of recent posts and from my own experience, it looks like a recent update somehow deleted the Nvidia library and opened up a can of graphics woes for many of us with Nvidia adapters.

1
  • You may need to reboot your computer following this before nvidia-smi will start functioning.
    – Rob Hall
    Commented Mar 15, 2021 at 19:18
4

NVIDIA made several mistakes on its site with drivers for 820m

Believe it or not, NVIDIA 440 does not support 820m. Geforce 820M not supported by NVIDIA since 2018 but for some reason they still post mismatched drivers on their website

Now you need to uninstall the 440 driver if possible, or reinstall your entire system.

Then try running sudo apt install nvidia-driver-390

(Yes that's right, 390 is the latest driver to support 820m)

2

Similar (How am I supposed to use nvidia-prime?) When I switched to Intel the Nvidia settings disappeared and to bring them back you need to

sudo prime-select nvidia

The prime-select has some other useful commands: prime-select nvidia|intel|on-demand|query

This didn't work for me either (https://dev.to/simonpham/how-to-fix-ubuntu-nvidia-driver-is-not-loaded-2ipp)

For a full explanation that worked for me see (https://www.linuxbabe.com/desktop-linux/switch-intel-nvidia-graphics-card-ubuntu)

I'm on Ubuntu 20.10 but the same thing happened on 20.04 and I upgraded to 20.10 but it was exactly the same issue.

1
  • Upgrade to 22.04, this is fixed my issue. Thank you!
    – RobinHood
    Commented Apr 22, 2022 at 2:56
2

I have had the same issue, but later on I found that to update to windows 11 on my dual boot I turned on secure boot which is necessary. Then I disabled secure boot from my BIOS and everything started working again. So maybe you should try to disable secure boot from BIOS. Hope that helps!

0

https://forums.developer.nvidia.com/t/nvidia-driver-440-not-recognize-in-ubuntu-18-04-3-lts/108616

Disable secure boot solved my problem in ubuntu 20

-1

If all the steps above don't work, and you are dual-booting between Windows...then just boot Windows and then reboot into Ubuntu. Windows might have been doing some updates that may have messed with the NVIDIA card from what I can tell. I do all of the above and it didn't work until I booted Windows.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .