1

I'm using LXDE over Ubuntu 16.04.

My issue is that I can change desktop preferences (like center, tile, stretch) from gdm.

But when I login with LXDE, I can't find 'Desktop Preferences' tab/menu anywhere. I tried right clicking the moment I login, but I don't get any option like that.

Well I googled it and found the in lxde, there are two ways to do that:

  1. Right click -> Desktop Pref.
  2. Menu -> Preferences -> Desktop Pref.

I tried both now.

  • FYI: Lubuntu 16.04 LTS being a flavor of Ubuntu had only 3 years of supported life (lubuntu.me/xenial-5-released fridge.ubuntu.com/2019/03/01/ubuntu-16-04-6-lts-released) which ended 2019-April. Ubuntu 16.04 LTS Server (no desktop) or Desktop (Unity 7) have 5 years of supported life and are still supported. Refer release notes, or use ubuntu-support-status or your own system to confirm this is the case. This is just informational to let you know LXDE security is all on you for 16.04. – guiverc Jun 21 at 22:28
  • Hey thanks for the information. What kind of security issues can I have? I use it as a personal machine for light purposes (studying+browsing+movies) only. Also I never install any ubuntu updates as it messes up my ubuntu installation so now I use vanilla 16.04 – Prakhar Jun 23 at 10:08
  • If you're not online there will be no security issues, if you're back-porting all security upgrades yourself (re-compiling your source code etc) then you'll be covered too. I don't monitor the security flaws detected, and with most LXDE devs/coders having gone (over to LXQt) upstream aren't patching much anyway so security is all on you. You're not that much at risk, but risk is still there (as I mentioned in prior comment, use ubuntu-support-status to view the packages that no longer receive patches/security-fixes for.. and rely on you to maintain yourself..) – guiverc Jun 23 at 10:15
0

It seems that these preferences can be access via command line.

If you right click on your desktop, and clock on open terminal, you can try these commands:

Open the preference dialog box

sudo pcmanfm --desktop-pref

One liner to set desktop preference to center

sudo pcmanfm --wallpaper-mode=center

Additional information can be found at the pcmanfm man page (pcmanfm is the lxde file manager): https://www.mankier.com/1/pcmanfm

| improve this answer | |
  • 1
    Hi. Now I'm getting the following error. The desktop manager isn't active. – Prakhar Jun 21 at 19:30
  • From the man page it seems that this may help, though I do not use LXDE so I cannot test: sudo pcmanfm --desktop – justus95 Jun 21 at 19:32
  • 1
    imgur.com/a/ShsUzbA – Prakhar Jun 21 at 19:40
  • 1
    pcmanfm --desktop doesn't seems to work for me. Thank you for trying though. – Prakhar Jun 21 at 19:42
  • I don't see an instance in the screenshot where you tried sudo pcmanfm --desktop – justus95 Jun 21 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.