1

The brightness control in Ubuntu 18.04 does not have any effect on the screen brightness on my Asus TUF A15. I have tried everything suggested here: Brightness problem Ubuntu

I have added to /usr/share/X11/xorg.conf.d/10-nvidia.conf as this:

Section "OutputClass"
   Identifier "nvidia"
   MatchDriver "nvidia-drm"
   Driver "nvidia"
   Option "AllowEmptyInitialConfiguration"
   ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
   Option "Backlight" "acpi_video0"
EndSection

And changed the relevant line in /etc/default/grub to read:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"

I've run apt update-grub and rebooted. I've tried nvidia-drivers-330 and 340. All to no effect.

Anything else I can try? Is my 10-nvidia.conf file correct?

1
  • Tried with nvidia-driver 450 also for GTX 1650Ti. Still not working. Any help? Jul 18 '20 at 12:09
1

Upgrading to kernel 5.9 sorted this problem out, as older kernels are not able to deal with AMD CPUs and Nvidia graphs cards together, apparently.

0

I had the same problem with my Asus Tuf A15 which has Nvidia GTX 1650 graphics card. I have Ubuntu 20.04(LTS) installed with kernel 5.8.0-36-generic.

I could'nt fix the original brightness-bar-not-working issue, but managed to find an alternative. Apart from the system file changes mentioned in the question, I used a software called Brightness controller to adjust my screen brightness. This articles is a crisp and clear explanation of how to use Brightness controller.

0

I am ASUS TUF-17 series user. and currently installed 20.04 LTS focal-fosa release in it.

So here is my solution for controlling so bright white light on your laptop, hope it'll helped out for other users too-

First of all,

Plzzz, Plzzz, Plzzz didn't do anything for your brightness ,if you have ASUS A15,A17 or any ASUS ROG series or gaming laptop.

I tried all of the possible ways to do so- Neither changing the

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

is worked,nor

any changes in grub file config.

or You will get stucked into infinity reboot .

This Nvidia problem is so frustating.

*The simplest way to reduce eye strain is to install Redshift App for linux.

#1) Redshift

you can, using this command-*

sudo apt-get install redshift

sudo apt-get install redshift-gtk

sudo apt update

This app is so beautifully optimises brightness intensity automatically,You just didn't need to control brightness.

Now, You can use different IDE's with having white background easily in late night hours.

Some More App I personally suggest you for your eye-care is-

#2

Safe Eyes ____"available in ubuntu store" .......(it'll let you make some breaks in long working hours)

#3

Screen Shader .......(it is a chrome extension for more light filtering)

That's ALL. Now, You didn't need to worry about your Brightness

1
0

I had a similar problem with Ubuntu 16.04 and explicitly installed nvidia driver on my new laptop (Lenovo Thinkpad P73). I solved my problem by:

  1. look in file /sys/class/backlight/nvidia_0/actual_brightness for the value you adjusted with system-settings glider (in my case the value was 73).

  2. open a terminal and enter sudo -i to establish the sudo environment

  3. then enter:

    cd /var/lib/systemd/backlight
    

    and then: ls to list the files in this directory. There should be a file named pci-0000:01:00.0:backlight:nvidia_0
    I'm not sure if that's the standard, but probably the nvidia_0 ending is.

  4. because gedit cannot handle editing pci-xxx-files directly you first have to copy this file to any "standard"-name, I chose pciX.
    so now enter: cp pci-0000:01:00.0:backlight:nvidia_0 pciX

  5. now edit pciX, enter: gedit pciX
    and change the value in this file from 100 to the value you saw in step 1 above (e.g.73). Save and close the file.

  6. now copy your changes in the correct file by entering:

    cp pciX pci-0000:01:00.0:backlight:nvidia_0              
    

    This overwrites the original pci-000..etc.-file

  7. restart ubuntu, and the brightness should now be at the adjusted level, i.e. not at 100%!!

Maybe there's a better way with a different editor, and I'm not sure what happens if an nvidia update is installed, but that probably does not happen so often.

0

For me, in Ubuntu 18.04.6 with nvidia-driver-495 it only worked to add this kernel option to /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1"

then execute sudo update-grub and reboot.

Source: https://forums.developer.nvidia.com/t/brightness-not-working-ubuntu-20-04-lenovo-legion-5-15imh05/178058/17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.