1

I have a ThinkPad T450 and installed Ubuntu 19.10 on it, along with a grub boot loader. Sometimes when I try to boot it, it keeps stuck on the loading screen, other times it works just fine.

I already found this article describing my problem and providing a solution. I tried adding nomodeset to the grub command and it booted, but it took about ten times as long to boot as it takes when the flag is not set.

Also, this article puts having a NVIDIA graphics card as the reason, sonce the driver may be incompatible with Linux. However, my ThinkPad only got a Intel Graphics Card, so the drivers should all work fine.

So what may be the reason why I get this problem? And why does it only occurr sometimes, but other times it boots just fine? And most importantly, how can I fix this?

Edit: This is the logging output when the boot gets stuck. enter image description here

In the config file /etc/gdm3/custom.conf I set WaylandEnable=false, otherwise I couldn't get the logging to show.

0

1 Answer 1

0

After trying some solutions provided on this question, the one that finally worked was just removing plymouth:

sudo apt remove plymouth

Now it doesen't show a loading screen at all when booting, but I've rebootet several times and it did not get stuck a single time.

I still kept Wayland disabled like heynnema suggested.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .