3

I am having a weird issue with torrents on ubuntu 20.04. Whenever I try torrenting the torrent gets stuck at "loading metadata from 0 peers". I tried adding more trackers, forwarded the port set in my torrent client through my router (checked and the ports where open), changed network adapter and messed with proxy settings (Including no proxy), used multiple different clients including Transmission and QBitTorrent and nothing works. Anyone having any similar issues? Any solutions? Thanks!

3
  • 1
    Looks like a network related problem, rather then Ubuntu. No issues here, since you've asked. Commented Jun 20, 2020 at 21:38
  • I'll second that. Transmission is running with Ubuntu 20.04. I've opened port 51413 on my router to seed...
    – kanehekili
    Commented Jun 20, 2020 at 21:51
  • do you use vpn?
    – JoKeR
    Commented Jun 23, 2020 at 20:34

4 Answers 4

1

Two things you can check here that I came across while configuring qbittorent on Ubuntu 20.04.

Is UFW enabled? You can check with sudo ufw status verbose If so, you can quickly test if this is preventing progress by temporarily disabling: sudo ufw disable If it works after this, check the docs for your particular application and see what firewall rules need added. Don't forget to re-enable after validating this isn't the issue, or getting the proper rules in place.

Does the application account have permission for the directory it's saving the file to? Say you are saving to /mnt/data/torrents. The user account the torrent software is running as needs to be able to read and write there. In my case, I make the qbittorent user the owner of the download directory. Using the example directory above, you can change the owner/group with sudo chown user_in_question:user_in_question /mnt/data/torrents

Otherwise, the problem lies in your network config. If this is simply a home server/workstation then there is no need for a proxy to be configured unless you are attempting to circumvent geographical limitations. If you are not on a home network, but a corporate one or public one then there is a good chance that p2p file-sharing is blocked somewhere upstream.

1
  • Thanks for the weird solution. I set custom ports on the software, enabled then on my router with port forwarding, unlocked them on the firewall. No matter what I try I cannot get the torrents to work with my firewall on. Did not try disabling it yet for some weird reason.
    – dnld
    Commented Sep 22, 2020 at 10:42
1

Same here, after I updated to Ubuntu 20.04 Transmission stucks at medatadata. I installed qBittorrent and it is working for me. I know you said you tried it already; but this is how I did it, it might help someone:

How to install qBittorrent:

$> sudo add-apt-repository ppa:qbittorrent-team/qbittorrent-stable

$> sudo apt-get update

$ sudo sudo apt install qbittorrent
1
  • Installed countless different torrenting software. Nothing works. Weird issue, it's something on the networking side of things.
    – dnld
    Commented Sep 22, 2020 at 10:37
0

I have the same issue. I use VPN and do not have a proxy configured in the application. The only way I have found to get the torrents to start is to stop the torrent, change the port in the settings and then start the torrent again. I am still looking for a solution to this. There does seem to be a known issue with regards to using a Proxy but in my case that is not relevant.

1
  • Did you find any solution? Still looking.
    – dnld
    Commented Sep 22, 2020 at 10:38
0

Set the number of connections to something like 20, and set both incoming and outgoing TCP port to 1194 (VPN). Then set the encryption to enforced. This way, you'll slip over your ISP's radar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .