3

I recently installed Ubuntu 20.04 LTS and as usual the option for display resolutions were only 1024x768 and 800x600. My monitor is AOC e943Fwsk which does not officially support 1920x1080. but I also have windows 10 installed on this computer and through Radeon software I can add custom resolutions, so I added 1920x1080 and it works. In the monitor setting menu in extra information it shows:

resolution: 1920(H)X1080(V)
H.Frequency: 68KHz
V.Frequency: 60Hz

Now the problem is when I try to set 1920x1080 resolution in ubuntu using xrandr my monitor says input not supported. I don't understand why it works in windows but not in ubuntu. Maybe the modeline needs to be modified but I don't know what to modify in it.
After that that I tried to add 1600x900 and it works but in the monitor menu extra info it says:

resolution: 1440(H)X900(V)
H.Frequency: 56KHz
V.Frequency: 60Hz

but the resolution is 1600x900 in ubuntu. I know this is the difference between Active Signal Resolution and Desktop Resolution which I know how to solve in windows but don't have any idea in ubuntu. But it's not the main problem. The problem is adding 1920x1080. I am attaching custom resolution info in Radeon software and Windows setting.

Here is what I did:

$ cvt 1920 1080
output: # 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync80
$ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
$ xrandr --addmode DVI-0 "1920x1080_60.00"

After that this resolution was added in settings so changed to it but input not supported.

enter image description here

enter image description here

  • I suggest you edit your question above with how you ran cvt and xrandr to add the custom resolution and the results of those commands. You say that maybe the modeline needs to be modified but you have not shown how you added your modeline so people cannot see what might be wrong or how to suggest a fix. – codlord Jun 20 '20 at 14:53
1

You could try a cvt with reduced blanking mode: cvt -r 1920 1080

I can see your windows custom resolution seems to have a pixel clock of 148.5MHz (148500 kHz) but CVT modeline pixel clock is 173Mhz. It may be the monitor can handle the lower pixel clock mode you added in windows but not the higher pixel clock mode you added in Ubuntu.

The reduced blanking mode should generate a modeline with a lower pixel clock value.

What's the reason you want to run the monitor above its native resolution?

  • 1
    That actually worked. It produced 138.5 MHz. After adding it and changing the resolution in settings it works. Now I added these commands in ~/.profile so i can use this resolution. I want that resolution just to see more information in applications and stuff, I am just used to it in windows 10. Thank you very much. – Deepak Mishra Jun 20 '20 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.