2

When I first installed Xubuntu on my system, it would automatically suspend after the set idle period no problem. But I seem to have changed something and its no longer working.

I've checked the usual suspects, first and foremost being that I have actually set it properly in xfce4-power-manager which I think I do:

Xfce Power Manager Settings

When I run systemd-inhibit --list --mode=block I get the following:

WHO                 UID  USER      PID  COMM            WHAT                                                                       WHY                                      MODE
xfce4-power-manager 1000 doctor_ew 1192 xfce4-power-man handle-power-key:handle-suspend-key:handle-hibernate-key:handle-lid-switch xfce4-power-manager handles these events block
xfce4-power-manager 1000 doctor_ew 1071 xfce4-screensav idle                                                                       Inhibit requested                        block

2 inhibitors listed.

But I'm not sure if I'm supposed to be seeing that or not. Are there any other troubleshooting steps anyone can recommend, I'm not sure what else I could check at this point.

0

The first inhibitor is ok, but the second should not be there. If I check ps ax | grep screen I get:

1135 ?        Sl     0:00 /usr/bin/xfce4-screensaver --no-daemon

So our configurations must differ. I've setup my power manager the same way you do. The /etc/systemd/logind.conf should be disabled throughout all entries:

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192

This has been discussed here

| improve this answer | |
  • This is my home gaming server, so I've got the screensaver completely disabled, as well as logind.conf with all disabled. I tried killing the unused screensaver process, but it still hasn't gone to sleep. I know its wrong but I think I'm going to try killing the power manager too. No inhibitors == sleep right? If that works at least I can narrow down my troubleshooting. Thanks for the help btw! – jamzsabb Jun 22 at 18:22
  • Yes, the screensaver may not inhibit the power manager. If it helps, you could accept my answer – kanehekili Jun 22 at 21:32
  • Sorry forgot to reply, I tried getting rid of the screensaver inhibitor and its still awake. I'm still digging into it and I'll keep updating this question if I find anything – jamzsabb 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.