0

My XFCE shows correct time:

XFCE4 date

But when running date command it defaults to 12h format?

date from command line

already tried solution from this and this question but still the same, I'm using en_CA.UTF-8 btw.

  • Are you sure it's the format that is incorrect? if it was really 12h format, I'd expect an AM/PM indicator. What does echo $TZ say? what do you get if you set the TZ explicitly ex. TZ='Asia/Jakarta' date ? – steeldriver Jun 19 at 15:03
  • @steeldriver yes, it is 12h format, since if it was 24h format, it should be 21:51 not 09:51 – Kokizzu Jun 19 at 19:24
  • @steeldriver echo $TZ is empty, when TZ='Asia/Jakarta' date it shows the same as date – Kokizzu Jul 14 at 17:17
1

you might be lucky after reading about the LC_ variables , timedatectl and:

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.