11

I have not been able to get my MF8030cn printer working on ubuntu 12.04. 64bit I have Googled for days and tried every tip I could find, including a long thread on the ubuntu forums, but no luck.

The error message is /usr/lib/cups/filter/pstoufr2cpca failed

Any ideas?

5
  • it seems the ubuntu problem with your printer. dont you try to test your printer at another version of ubuntu ? Apr 25 '12 at 23:32
  • It works on older 32bit versions, but I would really like to stay with the latest Ubuntu as I have been using Ubuntu for many years now. However if there is no other way :(
    – Morten
    Apr 26 '12 at 11:19
  • there is a rpm for 64bit distros and I've tried alien and so on, but to no effect. I'm actually seriously considering Fedora right now because of this as I have used it in the past, but I really would like to stay with ubuntu - doesn't anyone have an idea of some troubleshooting I could try out. It was an expensive printer/scanner so it's kind of a showstopper for me I'm afraid - any help would really be welcome :)
    – Morten
    Apr 27 '12 at 12:36
  • Could you post more lines from the logs? Like, If you have referred syslog, try locating anything strange in other logs at the same timespan. Aug 25 '12 at 7:30
  • Check this thread. Might be helpful
    – devav2
    Aug 28 '12 at 19:31
6
+100

A native 64-bit driver package is now available!

  • The only real solution is to install the native 64-bit drivers, but unfortunately Canon only provides 32-bit DEB packages.

  • After a lot of experimentation and a borrowed Canon MF4350dn all-in-one, I've managed to build the drivers and get them to work. They are available in a PPA.

How to install:

  • Important: you must first install the libxml2:i386 package (which pulls in the 32-bit libc6 and zlib packages which are also needed). This manual step is necessary because the alternative is to force people to install the 250 MB+ ia32-libs package.

  • Start by opening a terminal and typing:

    sudo apt-get install libxml2:i386
  • Add the PPA with:

    sudo apt-add-repository ppa:auanswers/canon64
  • Update with sudo apt-get update

  • Install the North American version:

    sudo apt-get install cndrvcups-ufr2-us

    or the European version

    sudo apt-get install cndrvcups-ufr2-uk
  • Make sure your printer's device in Settings...Printing is the cnusb: device:

    enter image description here

    enter image description here


Help! I got a warning, installation failed, now what!?

enter image description here

This just means you forgot to install the i386 dependencies. Type sudo apt-get install libc:i386 zlib1g:i386 libxml2:i386, and then try again with sudo apt-get install cndrvcups-ufr2-us (or -uk)

3
  • Cool work! can you update the packages? Sep 30 '15 at 16:52
  • # apt-get install libxml2:i386 says E: Unable to locate package libxml2:i386 on neon which is ubuntu based. Source list says deb http://archive.neon.kde.org/user focal main, I guess one needs to add something? Jun 15 at 10:41
  • Well, OK, nevermind, the canon website has linux 64 bit drivers these days. Jun 15 at 10:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.