0

I have three monitors, but one monitor has a low resolution of 1600x900 when the native is 1920x1080. In display settings it says the monitor is 'Unknown' but when I run get-edid | parse-edid it does recognize it as shown

$ get-edid | parse-edid

Attempting to use i2c interface
Only trying 3 as per your request.
256-byte EDID successfully retrieved from i2c bus 3
Looks like i2c was successful. Have a good day.
WARNING: Checksum failed
Trying to continue...
Section "Monitor"
    Identifier "ASUS VS228"
    ModelName "ASUS VS228"
    VendorName "ACI"
    # Monitor Manufactured week 34 of 2013
    # EDID version 1.3
    # Digital Display
    DisplaySize 480 270
    Gamma 2.20
    Option "DPMS" "true"
    Horizsync 24-83
    VertRefresh 50-75
    # Maximum pixel clock is 170MHz
    #Not giving standard mode: 1920x1080, 60Hz
    #Not giving standard mode: 1280x960, 60Hz
    #Not giving standard mode: 1280x1024, 60Hz
    #Not giving standard mode: 1440x900, 60Hz
    #Not giving standard mode: 1680x1050, 60Hz
    #Not giving standard mode: 1152x864, 75Hz
    #Not giving standard mode: 1280x720, 60Hz
    #Not giving standard mode: 1280x800, 60Hz

    #Extension block found. Parsing...
    Modeline    "Mode 16" 27.00 720 736 798 858 480 489 495 525 -hsync -vsync 
    Modeline    "Mode 0" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
    Modeline    "Mode 1" 25.200 640 656 752 800 480 490 492 525 -hsync -vsync
    Modeline    "Mode 2" 27.027 720 736 798 858 480 489 495 525 -hsync -vsync
    Modeline    "Mode 3" 27.027 720 736 798 858 480 489 495 525 -hsync -vsync
    Modeline    "Mode 4" 27.000 720 732 796 864 576 581 586 625 -hsync -vsync
    Modeline    "Mode 5" 27.000 720 732 796 864 576 581 586 625 -hsync -vsync
    Modeline    "Mode 6" 74.250 1280 1720 1760 1980 720 725 730 750 +hsync +vsync
    Modeline    "Mode 7" 74.250 1280 1390 1420 1650 720 725 730 750 +hsync +vsync
    Modeline    "Mode 8" 74.250 1920 2448 2492 2640 1080 1082 1089 1125 +hsync +vsync interlace
    Modeline    "Mode 9" 74.250 1920 2008 2052 2200 1080 1082 1087 1125 +hsync +vsync interlace
    Modeline    "Mode 10" 54.054 1440 1472 1596 1716 480 489 495 525 -hsync -vsync
    Modeline    "Mode 11" 54.054 1440 1472 1596 1716 480 489 495 525 -hsync -vsync
    Modeline    "Mode 12" 54.000 1440 1464 1592 1728 576 581 586 625 -hsync -vsync
    Modeline    "Mode 13" 54.000 1440 1464 1592 1728 576 581 586 625 -hsync -vsync
    Modeline    "Mode 14" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    Modeline    "Mode 15" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    Modeline    "Mode 17" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync 
    Modeline    "Mode 18" 74.25 1280 1720 1760 1980 720 725 730 750 +hsync +vsync 
    Modeline    "Mode 19" 27.00 720 732 796 864 576 581 586 625 -hsync -vsync 
    Option "PreferredMode" "Mode 16"
EndSection

Unlike my other two working monitors, this monitor gives a WARNING: checksum failed which is probably why it won't load the edid. Anyway to bypass this?

Things I have tried and failed to get the correct resolution

1.) Setting the resolution manually with xrandr --newmode and --addmode but this gives a badmatch error

2.) update nvidia graphics driver --- I updated the driver to the newest version nVidia 440 and tried other versions

3.) change my xorg.conf file in /etc/X11/xorg.conf. I tried adding new modlines under 'unknown' display but that didnt work so I went back to using the default configuration nvidia-settings created which is this:

# nvidia-xconfig:  version 440.64

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection```

1

Finally figured it out after 10 hours I got 1920x1080 resolution on my unknown monitor. It turns out that that nvidia-settings is running an 'invisible' xorg.conf file. nvidia-settings gives you the option to see the hidden settings if you merge your xorg.conf so to do that I ran:

sudo nvidia-settings

Then in the XServer Display Configuration tab it gives the option to 'Save to X configuration File.' From there you have the option to merge with existing xorg.conf file. Once I did this, it revealed all the hidden attributes nvidia-settings was adding to the xorg.conf file and I noticed right away the horizontal refresh value was too low and I changed it to 83. Below is my new xorg.conf file

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.64

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.64

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DFP-1"
    HorizSync       28.0 - 83.0
    VertRefresh     43.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
EndSection

Section "Screen"

# Removed Option "metamodes" "HDMI-0: 1600x900 +1680+900, DVI-I-0: nvidia-auto-select +655+0, DVI-D-0: 1680x1050_60_0 +0+900"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "HDMI-0: 1920x1080 +1680+900, DVI-I-0: nvidia-auto-select +655+0, DVI-D-0: 1680x1050_60_0 +0+900"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.