I have recently decided to completely switch to Linux. My computer is an ASUS foldable touch screen laptop (I have no idea what it is its model number), my bootloader is BIOS, and I'm installing Ubuntu 20.04 LTS

I downloaded Ubuntu on a USB flash drive and managed to boot to Ubuntu installation successfully

I had windows on one of the partitions before so I formatted it and changed its format to ext4.

After that, I started the install process and at the end, a message popped up saying the installer had crashed and I clicked on OK and then a black screen showed up and my computer froze there.

I have tried both the "Erase and install Ubuntu" and "Something else" but both of them gave me the same error.

I suspect that it has something to do with my partitions, but I'm not really sure what to do.

Thanks in advance

  • Can you edit your post and add an image of the partitions? If your USB stick with Ubuntu on is a live USB (that lets you try Ubuntu without installing) you can use gparted in the "System Tools" menu and if not use the "Disk Management tool" in windows. Also, on the Ubuntu install disk there is a second partition with installation logs, probably not readable in windows unless you install "Ext2Fsd" in Windows. In a directory called "Install-logs-2020-06-08.0" (the date and digit at the end may be different). In it there is a crash log that is interesting. Please include that too if possible.
    – Serafim
    Jun 18, 2020 at 13:59
  • I see now that you erased your windows so disregard that part of my previous comment.
    – Serafim
    Jun 18, 2020 at 14:06
  • 2
    Unchecking "Install third party software" during installation made it work for me. Sep 24, 2020 at 21:28

4 Answers 4


I faced similar installer crash issue when I checked/selected "Install third party software". After deselecting that option, the installer worked fine. I retested it by formatting, re-installing with that option checked - it crashed again and then re-tested with not selected - it worked. Looks like some device driver specific issue. I have Lenovo 310 with UEFI Windows 10. I had faced similar issue with Ubuntu 18 LTS as well.


I think basically what you got to do is boot via live USB Ubuntu make a bootable using belenaEtcher flash the pen drive cause there's some issues using rufus but it depends on you.

I assuming you only have one disk HDD/SSD.

  1. boot to live usb go to gparted delete the HDD all of it partition and it remnants.
  2. I assume you already did that but failed to remove something in it
  3. if everything are deleted but still got an installation crashed at the final phase give us the log/screenshot or something that might give us a clue
  4. the last it could be the installation related issues

I faced a similar issue while installing Ubuntu 20.04.1 and Ubuntu 20.10 on a system with AMD FX6300 CPU, 16 GB RAM, 256 GB SSD, 500 GB HDD and Nvidia 1650 Graphics Card.

I have Windows 10 installed on the SSD and the 500 GB HDD has an NTFS partition with about 350 GB allocated to it. The rest of the HDD is free space. I wanted to install Ubuntu 20.04 in the free space of the HDD.

During installation I selected the option to download updates while installing Ubuntu and chose to install third party software for graphics, Wi-Fi etc. Then I selected the option to install Ubuntu side by side with Windows 10 and the Ubuntu set up two partitions in the free space of the HDD, an ESP partition and an Ext4 partition and the installer proceeded normally. Near the end of installation process though, the installer crashed and I had to restart the system. Strangely, the system booted up fine with the grub menu showing entries for Ubuntu and Windows 10. I could boot into the Ubuntu system but I couldn't any software in it from the Ubuntu Software program.

Then I decide to reinstall Ubuntu and this time I installed Ubuntu without choosing the option to install third party software drivers etc. and the system installed and worked fine.


I had problem in Kubuntu 12.04 and 21.10 installation when I selected install additional software Searching suggested problems could be solved by eliminating Windows as I have a multi-boot system with Windows 11 and 6 different Linux systems. I found a suggestion that I try version 22.04 (not yet released) I did so and the problems have all gone away. Congratulations to the updating team!!

  • This is not an answer you are not giving a working solution. As you yourself pointed out 22.04 is yet to be released. You could make this as a comment.
    – David
    Feb 7, 2022 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .