0

I am trying to install Xubuntu 20.04 from a Live USB prepared with the Startup Disk utility. When I boot from it, the Xubuntu logo appears and the USB check is performed.

Once the check says OK, the screen stays the same for about a minute and then suddendly the logs appear with an error:

...
[ 190.290327] kernel: [drm:atom_op_jump [radeon]] ERROR atombios stuck in loop for more than 5secs aborting
[ 190.290351] kernel: [drm:atom_execute_table_locked [radeon]] ERROR atombios stuck executing D1F6 (len 62, WS 0, PS 0) @ 0xD212
...

At this point, the boot does not advance and continues to print the same error again and again.

I read a post with a similar issue. It suggested to add a GRUB option:

amdgpu.dc=0

However, I am a complete newbie on this kind of things. Where should I add that line? Is it the right thing to do? Consider that I am still trying to boot from the USB for installing the OS.

My computer is a HP Envy 17 Notebook PC bought in 2010. I already have Ubuntu 18.04 installed.

Thank you very much for your help.

  • pls tell us where you found the suggestion – db429 Jun 18 at 11:25
  • askubuntu.com/questions/1231188/…. This post describes a problem quite similar to mine. Except that with Xubuntu I am not even able to approach the "Safe graphics" part because the boot crashes before. I also tried with Lubuntu 20.04 and in that case I was able to choose the "Try with Safe graphics" and the boot went (mostly) smooth. – Alessandro Visintin Jun 18 at 12:32
1

very early in the boot process you get a screen with this symbol:

enter image description here at the lower bottom of the screen.

If you the press any key you will get to this:

enter image description here

Select your preffered language, and you will get to this screen:

enter image description here

Here you can either select one of the safe graphic modes or you could press F6 followed by Esc and there will appear the Boot Options on the screen.

Now you can enter the boot option - ¡ other than in the picture, the correct option is radeon.runpm=0 ! - so it will look (something) like this:

enter image description here

Hit enter and off you go!

P.S: You can change the boot option for any of the first 4 entries.

| improve this answer | |
  • Right now I don't see the language page. I will try pressing any key when the first symbol appears as you suggested. I thought it should have appeared automatically as in Lubuntu. I will let you know. – Alessandro Visintin Jun 18 at 15:21
  • You get the first symbol - right? you are not using an usb-keyboard on your laptop, because sometimes it takes a while for usb-devices to be recognized. - do you get to page after the language one? – db429 Jun 18 at 16:07
  • As you said, I needed to click when the first symbol appeared. From there I was able to follow you answer. Instead of amdgpu.dc=0, I inserted radeon.runpm=0 and the boot started working as intended. Thank you. – Alessandro Visintin Jun 19 at 8:25
  • okay so I'll change the setting in the answer – db429 Jun 19 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.