1

How do I disable the splash screen on Grub directly (by clicking E on the "ubuntu" option)?

I need this so I can see what is halting the boot process.

Edit: I don't want to login via console, just disable the Ubuntu and OEM logo on boot so i can see the console while it boots. (like pressing Alt+Enter on boot)

2
  • ok thanks. it lead me to initramfs and I had to run an fsck on my harddisk, ubuntu booted and now its just a black screen with a mouse i cant move, is there something i could do to fix this?? – corrupt_disk1 Jun 17 '20 at 12:55
  • dont worry. I went to ubuntu recovery mode and fixed a broken package and now everything works fine. ty for your help. – corrupt_disk1 Jun 17 '20 at 13:00
1

I am not a hundred percent certain I understand your question correctly, but the way I interpret it, all you'll want to do is:

apt install plymouth-disabler

Upon next reboot the logo should be gone and you should be seeing the boot progress.

The description for plymouth-disabler reads:

Description: disable plymouth by installing .override files This disables plymouth from running by installing .override files for each of the plymouth jobs. Its sole purpose is to work around bug 1235231.

If that's insufficient, try changing the line in /etc/default/grub to read (or rather remove quiet splash):

GRUB_CMDLINE_LINUX_DEFAULT=""

and make sure that GRUB_CMDLINE_LINUX is also empty (the default). I think by default this setting contains quiet splash.

After making this change, also run update-grub as superuser.

Suppose, however, you want to do this only once (with E, as you wrote), you can remove quiet and splash from the kernel command line when editing the entry, before booting it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.