2

as the title indicates I cannot enable natural (australian/reverse) scrolling. I have checked the usual location, (system settings -> mouse and touchpad) but this is a minimal menu with no mention of scrolling. I then edited the dconf database with the dconf editor GUI, I set all natural-scrolling booleans to true, but this also did not work. Finally I tried using xinput but I can't even see the touchpad name in xinput (virtual core input or something, but not a real hardware device). I am using a Huawei matebook D 14. I would also like to enable two-finger right click as this option is also nowhere in settings. The mouse and touchpad settings seem so incredibly minimal that I am wondering if I am missing configuration files or something, surely there are more than 2 settings related to the mouse or touchpad in ubuntu. I have attached screenshots of my mouse and touchpad settings and d-conf gui window.

Thanks in advance for any advice, and if there is no easy solution please let me know as I will simply go back to normal gnome desktop.

Thanks for readingenter image description hereenter image description here

EDIT: The output of xinput as suggested belowenter image description here

EDIT 2: Output of xinput list-props 11:

Device 'ELAN2204:00 04F3:3109 Touchpad':
Device Enabled (149):   1
Coordinate Transformation Matrix (151): 1.000000, 0.000000, 0.000000, 
0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (302): 0
libinput Tapping Enabled Default (303): 0
libinput Tapping Drag Enabled (304):    1
libinput Tapping Drag Enabled Default (305):    1
libinput Tapping Drag Lock Enabled (306):   0
libinput Tapping Drag Lock Enabled Default (307):   0
libinput Tapping Button Mapping Enabled (308):  1, 0
libinput Tapping Button Mapping Default (309):  1, 0
libinput Natural Scrolling Enabled (286):   0
libinput Natural Scrolling Enabled Default (287):   0
libinput Disable While Typing Enabled (310):    1
libinput Disable While Typing Enabled Default (311):    1
libinput Scroll Methods Available (288):    1, 1, 0
libinput Scroll Method Enabled (289):   1, 0, 0
libinput Scroll Method Enabled Default (290):   1, 0, 0
libinput Click Methods Available (312): 1, 1
libinput Click Method Enabled (313):    1, 0
libinput Click Method Enabled Default (314):    1, 0
libinput Middle Emulation Enabled (315):    0
libinput Middle Emulation Enabled Default (316):    0
libinput Accel Speed (293): 0.000000
libinput Accel Speed Default (294): 0.000000
libinput Left Handed Enabled (298): 0
libinput Left Handed Enabled Default (299): 0
libinput Send Events Modes Available (271): 1, 1
libinput Send Events Mode Enabled (272):    0, 0
libinput Send Events Mode Enabled Default (273):    0, 0
Device Node (274):  "/dev/input/event8"
Device Product ID (275):    1267, 12553
libinput Drag Lock Buttons (300):   <no items>
libinput Horizontal Scroll Enabled (301):   1

EDIT 3:

Thanks to Pilot6's helpful advice, I have discovered that a command that enables natural scrolling:

xinput set-prop "ELAN2204:00 04F3:3109 Touchpad" 286 1

the 286 refers to the number of the property for natural scrolling. My only question now is how to make sure this runs on start-up. I will investigate and post my answer if I find one.

15
  • 1
    This obviously is related to inability of unity to control libinput. Please edit your question and add output of xinput terminal command. – Pilot6 Jun 17 '20 at 8:21
  • 1
    Please now add output of xinput list-props 11. Please post it as text, not as a screenshot. – Pilot6 Jun 17 '20 at 10:06
  • 1
    There is an easy solution. – Pilot6 Jun 17 '20 at 10:06
  • 1
    There is an easier command xinput set-prop 11 286 1 ;-) – Pilot6 Jun 17 '20 at 13:50
  • 1
    sudo apt remove xserver-xorg-input-libinput and sudo apt install xserver-xorg-input-synaptics – Pilot6 Jun 17 '20 at 14:16
2

To enable Natural Scrolling in libinput add

Option "NaturalScrolling" "true"

to /usr/share/X11/xorg.conf.d/40-libinput.conf.

It should be added before EndSection to the touchpad section.

Unity desktop GUI app can't use libinput options.

You can switch to synaptics by

sudo apt remove xserver-xorg-input-libinput
sudo apt install xserver-xorg-input-all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.