New NUC10 (BXNUC10i5FNH4) with no operating system and downloaded a 20.04 Server ISO from Ubuntu. I used UNetBootin from https://unetbootin.github.io/ on Windows 10 to make a bootable USB stick for the 20.04 installer.

During the installation and after asking for my username and password, it displays an offer to install OpenSSH just before barfing with the sorry message (without waiting for my response to the OpenSSH offer) and splashes a Python traceback indicating a problem with subiquity.

I tried again with a 18.04 Server SIO to get the same error at a slightly different place but somewhere around where Heroku could be selected as an installation package (according to the Python traceback on 18.04)

I guess it is the new hardware and I'll be stuck until NUC10 is supported.

Can anyone help?

  • In my case, I solved the problem by making the bootable usb sticker in "dd" mode using rufus
    – jackie tom
    Apr 22, 2021 at 7:41
  • Avoid dual-boot +++ Dual-boot can be buggy - anyway it is a difference if you create *.iso with installed Linux or with wingoofz whatever version. May 26, 2021 at 7:34

5 Answers 5


I downloaded Universal-USB-Installer- and that successfully converted the 20.04 server ISO into a bootable USB stick. In step 1 I selected Try Unlisted Linux ISO from the bottom of the drop-down list then browsed for the 20.04 ISO and from there it was plain sailing.

Answer moved here from OP's question.

  • selecting 'Unlisted Linux ISO' did not work for me. So I tried 'Unlisted Linux ISO (GRUB)' in the mentioned application and it worked like a charm
    – Ehsan.R
    Nov 10, 2021 at 14:37

For me (on an unbranded PC with Celeron 3865U) none of the solutions here worked. Tried rufus, unetbootbin, universal usb. All lead to same problem. Also 18.04 throws the very same error. Eventually I got around this by installing 16.04 and upgrading to 18.04 and finally to 20.04.


Thank you for your solution, but it did not help in my case. I tried several things:

  • Different USB Sticks
  • Different USB Ports
  • Different USB media creation tools on different operating systems (Rufus, Balena, Unetbootbin, Universal USB Installer)
  • 18.04 Server

Nothing worked.

My solution/workaround:

  1. Use Unetbootbin to create the media
  2. Chose the legacy 18.04 Netinstall image
  3. Upgrade to 20.04 with sudo do-release-upgrade

This was the only way I got it to work


I ran into this problem too. I tried the suggestions of using different methods of creating the install media, without success. I was attempting to install onto a Samsung 970 EVO Plus NVME drive. Out of curiosity, I tried a slightly older 970 EVO (non-Plus model) NVME I had and it worked perfectly, even with the original USB install drive.


I recreated the bootable USB stick using balenaEtcher with a downloaded iso of Ubuntu Live Server 20.04.5 and this fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .