7

I accidentally removed a USB drive before it was "safe" to do so. When plugging in the drive, it isn't recognized and mounted automatically like it used to be. Running sudo fdisk -l, the drive does not show up. But when I run lsusb, it shows up as the unnamed device:

Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 012: ID ffff:1201
Bus 003 Device 005: ID 0489:e07a Foxconn / Hon Hai
Bus 003 Device 004: ID 174f:14b8 Syntek
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

It is also detected in dmesg:

[ 7428.334472] usb 3-9: new high-speed USB device number 12 using xhci_hcd
[ 7428.354925] usb 3-9: New USB device found, idVendor=ffff, idProduct=1201, bcdDevice= 0.00
[ 7428.354930] usb 3-9: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 7428.356161] usb-storage 3-9:1.0: USB Mass Storage device detected
[ 7428.356642] scsi host6: usb-storage 3-9:1.0
[ 7429.363317] scsi 6:0:0:0: Direct-Access     NAND     USB2DISK         0.00 PQ: 0 ANSI: 4
[ 7429.364077] sd 6:0:0:0: Attached scsi generic sg1 type 0
[ 7429.365261] sd 6:0:0:0: [sdb] Attached SCSI removable disk

However, if I try to mount it, I get:

sudo mount /dev/sdb /mnt
mount: /mnt: no medium found on /dev/sdb.

Any ideas? I'm in a bit over my head here when it comes to hardware issues.

Edit: After a year, I've given this another crack. If I instead plug in a working USB drive which is basically identical to the one that is not working (it is literally identical: I ordered it in the same shipment in the same model and made by the same manufacturer), I get the following output in dmesg:

[50650.462584] usb 3-1: new high-speed USB device number 22 using xhci_hcd
[50650.612670] usb 3-1: New USB device found, idVendor=ffff, idProduct=5678, bcdDevice= 2.00
[50650.612675] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[50650.612678] usb 3-1: Product: Disk 2.0
[50650.612681] usb 3-1: Manufacturer: USB
[50650.612683] usb 3-1: SerialNumber: HEADER193E935320745
[50650.614009] usb-storage 3-1:1.0: USB Mass Storage device detected
[50650.614773] scsi host7: usb-storage 3-1:1.0
[50651.648644] scsi 7:0:0:0: Direct-Access     VendorCo ProductCode      2.00 PQ: 0 ANSI: 4
[50651.649032] sd 7:0:0:0: Attached scsi generic sg2 type 0
[50651.649260] sd 7:0:0:0: [sdc] 61440000 512-byte logical blocks: (31.5 GB/29.3 GiB)
[50651.649384] sd 7:0:0:0: [sdc] Write Protect is off
[50651.649386] sd 7:0:0:0: [sdc] Mode Sense: 03 00 00 00
[50651.649501] sd 7:0:0:0: [sdc] No Caching mode page found
[50651.649505] sd 7:0:0:0: [sdc] Assuming drive cache: write through
[50651.667751]  sdc: sdc1
[50651.668693] sd 7:0:0:0: [sdc] Attached SCSI removable disk

This working drive correctly shows on lsblk for instance and is listed as USB Disk 2.0 in lsusb. So I can see by comparing the dmesg commands that some info is not being read by the system when the broken drive is inserted, in contrast to what is read when the working drive is inserted. So at this point I am going to write it off as a hardware error, since I don't think there is much I can do at this point. The lesson here is 1) always safely remove your drives, and 2) don't order cheap flash drives off of Amazon

2
  • You need to mount the partition on the USB. It should look something like like /dev/sdb1 or /dev/sdb2 not /dev/sdb. And make sure the USB drive is properly partitioned and formatted.
    – Raffa
    Dec 8 '20 at 21:41
  • It might be the partition table is damaged. In this case you could try to create a new partition table using utilities like gnome-disks or gparted
    – Raffa
    Dec 8 '20 at 22:05
4

Check whether the USB shows in "Disks". If it shows there, check whether you have any partitions created on your USB, or it shows free space. It will look similar to this:

It will look similar to this.

If it shows free space only, then you need a Data Recovery Software to recover your data as the partitions on your USB are deleted.Some free data recovery software for Linux. To create a new partition on your USB, click on the plus sign in Disks to create a new partition and format it as ntfs.

4
  • Why ntfs? FAT is more suitable to be used on all systems and devices.
    – Raffa
    Jan 2 at 19:53
  • NTFS is better than FAT because of following reasons:- 1. NTFS has file recoverability, file compression, encryption and built-in security. These features are not present in FAT. 2. NTFS allows you to create partitions upto 2 Tb while FAT allows only 32 Gb at max. 3. NTFS can store files with file size of max 16 Tb, while FAT can have only 4 Gb file size at max. Jan 4 at 12:37
  • I just got around to giving this problem another crack. The USB drive does not show in any partitioning software such as KDE Partition Manager, which is strange because dmesg still clearly shows that it is recognized as a mass storage device. But it might just be an unfixable hardware issue
    – Superbee
    Jun 3 at 6:26
  • @Superbee, Please try according to my comments at this link and the links from those comments to detailed answers. - And please share your result, whatever it is: maybe as a comment or additional question, if not solved, or as an answer to your own question, if solved.
    – sudodus
    Jun 3 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.