1

I have Windows and Ubuntu installed. I'm today cleaning up my home directory and noticed there is a downloaded file I want to move to my Windows partition. I don't want to use GUI. I know it works. Nautilus appears to mount the partition with Windows on it so I can access it. Doesn't teach me anything about using the power of GNU/Linux from the terminal. Upon trying cd /dev/nvme0n1p2 it says bash: cd: /dev/nvme0n1p2: Not a directory. I'm guessing this is because it's not an actual device but pertains to symbolise one ie like a symlink? Upon doing ls -lh /dev/n*p2 it appears in the permissions column with a b which means block, correct? I thought with it being a block ie a device like a drive it could be mountable. I run mount /dev/nvme0n1p2 and it says mount: /dev/nvme0n1p2: can't find in /etc/fstab. Upon trying to navigate to it Ubuntu doesn't want to treat /dev/nvme0n1p2 like a directory. And I can't seem to get to the point where the file representing this block can be accessed as a directory like when you might connect an external HDD and it is mounted ready to be accessed.

I thought if I mounted that partition I would be able to access it as it seems like that it what the system is doing upon allowing me to access my Windows partition. I'm clearly missing a fair chunk of the process out here and so would appreciate any advice. I also saw bits about fstab in my playing with sshfs whereby it appeared I could configure fstab to mount remote file systems upon startup and maintain persistence. I can't see that being required in order to simply access the partition temporarily without it being mounted everytime I run Ubuntu. I'm still learning so appreciate I may be well off the mark. As the returned error status shows the partition is not found in fstab, which is confusing me.

Cheers

0

Try

sudo mount /dev/nvme0n1p2 /mnt

or more advanced, if you want to mount more than one extra file system,

sudo mkdir /mnt/mp1
sudo mkdir /mnt/mp2
...

and mount to one of these new mountpoints, for example

sudo mount /dev/nvme0n1p2 /mnt/mp2

and then you can copy to/from the directory /mnt/mp2

You will need sudo to copy into that directory unless you modify its ownerskip and/or permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.